summaryrefslogtreecommitdiff
path: root/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyscreenshot/pyscreenshot-2.3.ebuild')
-rw-r--r--dev-python/pyscreenshot/pyscreenshot-2.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild b/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild
new file mode 100644
index 000000000000..04cec4abf98f
--- /dev/null
+++ b/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python screenshot library"
+HOMEPAGE="https://github.com/ponty/pyscreenshot"
+SRC_URI="https://github.com/ponty/pyscreenshot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ media-gfx/pqiv
+ kde-apps/gwenview
+ x11-apps/xdpyinfo
+)"
+
+DEPEND="
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/entrypoint2[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/mss[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needs access to dbus
+ sed -i -e 's:test_kwin_dbus:_&:' \
+ tests/test_kwin_dbus.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx pytest -vv
+}