summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
commit0118ac4510d7b85ca62da20e4abd1286dd8bd752 (patch)
tree83ec10da0441d566914c9e66e10c8210202888ea /dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
parentea6f03ddd591a238d9c5004d5ffbfaf7215c01ee (diff)
gentoo auto-resync : 23:10:2023 - 02:38:53
Diffstat (limited to 'dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild')
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
new file mode 100644
index 000000000000..d4de03edcdef
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="
+ https://github.com/hamcrest/PyHamcrest/
+ https://pypi.org/project/PyHamcrest/
+"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}