summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
commit0118ac4510d7b85ca62da20e4abd1286dd8bd752 (patch)
tree83ec10da0441d566914c9e66e10c8210202888ea /dev-python/pyhamcrest
parentea6f03ddd591a238d9c5004d5ffbfaf7215c01ee (diff)
gentoo auto-resync : 23:10:2023 - 02:38:53
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest2
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index ff4698a401cc..6c14fc479a26 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,5 @@
DIST PyHamcrest-2.0.4.gh.tar.gz 59952 BLAKE2B 76d8bbe2581c178f26cabac5207b6f26f0e86d66848a51fb24d313fdafffc75d40a02f02a73462358ca55a6b50941f849c542340b854aed83a37cef5876d90e4 SHA512 6ee558fe04dce839d5d5d20b90ecf82fed96570e1c5b3a827fce19dba167bf4702ea707560b19e2d6e82be20913deb6cf17fa7e140733899a92abb28e9f2aa56
+DIST PyHamcrest-2.1.0.gh.tar.gz 62526 BLAKE2B 5f4a836c6f0e61977fe0d572987a75fa9803d2362afb95d27d22aa8a567844823452b99c40c8160cca4407a60dbbeff3f6fdf03163da9ee643e082a64e83c512 SHA512 99017a75954b346622f9bd261a4f8827f82eb42a19551a7f96f9097a763e57afcc367a41a4cca742bda60ee0e7c3bcc2ca7025348e318f41e67c97c7a60961b5
EBUILD pyhamcrest-2.0.4.ebuild 951 BLAKE2B ec1d6abdf7b06f08b4a3c13427fda7e1eb9a289eb9ac26b584edc073f067c5deca04b67abc6e7bce187de8b5446405fbec4e8cfeade2d203ccd992f599914e01 SHA512 b737091f9fcc6dceb976f5310349c4f78d2501516fc1c899e7f8aab4e9397530e0e6061782be13ec1d8d05fc1d8e007c412a4aaa9591572adadf1a1255de447e
+EBUILD pyhamcrest-2.1.0.ebuild 959 BLAKE2B 06b5316a8cffd6963eb383f87ac622d27c2ce26651cd49b1a97fedd8dd9c474bc37182344c1e4e069f5dc4436c20005c26d14f138166f5e1f975bd1c3e3d7c9e SHA512 70f515e4c85fa4ff09c68faa748ca29ee5477122e85896c6c50adba4582c2f74b34c6690fc89950ce8f625ce6b9d21337e860a9488a4c1c44f1753f45b06d592
MISC metadata.xml 397 BLAKE2B cfdb950c34749dd9fa17d822df0194a8f35e477902947cf568f76aed96588c0e5a903ea5448f9772faef06ddc66df3c3c971978c6f4431861bf3586702d610db SHA512 024f24f466f0212a7ac599638bcd42b858e2cc786b7bf2641d0e0d4cc3df5dc97c958d4d85930cbd1c32e023f755f844a2675e2c820839729c54ad5e8fb40cd6
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
new file mode 100644
index 000000000000..d4de03edcdef
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="
+ https://github.com/hamcrest/PyHamcrest/
+ https://pypi.org/project/PyHamcrest/
+"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}