summaryrefslogtreecommitdiff
path: root/dev-python/pygresql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/pygresql
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest4
-rw-r--r--dev-python/pygresql/metadata.xml1
-rw-r--r--dev-python/pygresql/pygresql-5.2.2.ebuild28
3 files changed, 28 insertions, 5 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index cb7fda382650..6b978150cc7c 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1,4 +1,4 @@
AUX pygresql-5.2-CFLAGS.patch 333 BLAKE2B caa18ab6ba4da14437637faf6cea4d27e829c4f547f9c08e33a452b1e5912a24235af823c9ea385bbd1516c0c80a08d3225e373ad64ad4d13873ff4dc5155695 SHA512 ddafaadb4ebfb68af71727f840f36800d3dd78323f8ab0324a16b50498206c8ac33c76a80f24fff7984195ed5ac0fc383bdcacb9ea334f4b47e5046864728cd0
DIST PyGreSQL-5.2.2.tar.gz 268818 BLAKE2B 4b74c5496f63208164efa10e70222b63512f3afb928bdc612f9874556ee2084b42a80ba05e9ebc6951c68c1c8a70c71320396aabb20b9d5c00d5edd46e287f3f SHA512 a88af2590a515ece19b7f64796e241c6e7b53c8aef90c6e2ae064298a4c71d44695dcf43e0e84595a704c4fdafb9abe35e1779492d3a9ad3708759215cb188a1
-EBUILD pygresql-5.2.2.ebuild 710 BLAKE2B 2beae939b8036e5256623cd786256afa35b386fdeac640df17c3b9c3224befc1ab371849035627cd7e0980be5a15a12bc44d35547e806e69838a8a092b0f1815 SHA512 571b0c4a9ec0046f9d51229678727134ed515c1736f0566d73e950ec31103eff4634a771559b4dd67bfc7fa2724ab831457575d8d5e73b1d1bfdf3328d271dc9
-MISC metadata.xml 453 BLAKE2B 357033b22b21d6be0febdd8c8a6fcaf3cb7dda7b6a1b144302ad6a653d70be3bb2015b3df9370c1e919a49f21516c2cf48790a2ab9a38381b83c2f9d9dbf89a3 SHA512 1ffce5d4bd23a6cca653389796a0e42cc4cdfe2e0f11516407f3da710524b80bbda3bd378614d6401970f4bad1769c00693a5ebb79ec8ce6281466613a1bb318
+EBUILD pygresql-5.2.2.ebuild 1181 BLAKE2B 4f3e79479615b2a7380a8c7933913456b91f8f038a7e4574ea1d33e81bac106ac0524d447514e4fe8f036774434cd14c624e3c07aa2068c08b6bc0d484b82e5b SHA512 f083dc3787267513a68f4edf04543e537e4432f0d8a541b33fb864abe1919151f1b4cb79bc1e56513bf5ea8cceb1bbbd7c0f531e6f93b0ca5453b1c6f9584b34
+MISC metadata.xml 510 BLAKE2B cde75458658f9434322620377e1f5b99c9a0aa484e164ab5dcdbee94e4beebe646ff052783984c95245791bb4006545037768928a6e2664e1bb72df5aea49ae7 SHA512 e5750c6fc17dc5368142847318bf1842a17e2f46ac1ef01aa4658ec1c51705c5f160e75018567f83f41b0b4fd226ef019779f406513cc2d5b9e68bf420b51b81
diff --git a/dev-python/pygresql/metadata.xml b/dev-python/pygresql/metadata.xml
index 3b27787860cd..5580fe606fcf 100644
--- a/dev-python/pygresql/metadata.xml
+++ b/dev-python/pygresql/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">PyGreSQL</remote-id>
+ <remote-id type="github">PyGreSQL/PyGreSQL</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pygresql/pygresql-5.2.2.ebuild b/dev-python/pygresql/pygresql-5.2.2.ebuild
index 578b5884f409..cf922e7456c7 100644
--- a/dev-python/pygresql/pygresql-5.2.2.ebuild
+++ b/dev-python/pygresql/pygresql-5.2.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
POSTGRES_COMPAT=( 9.6 {10..13} )
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 postgres
@@ -13,6 +13,7 @@ MY_P="PyGreSQL-${PV}"
DESCRIPTION="A Python interface for the PostgreSQL database"
HOMEPAGE="https://pygresql.org/"
SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="POSTGRESQL"
SLOT="0"
@@ -21,8 +22,29 @@ KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ~sparc x86"
DEPEND="${POSTGRES_DEP}"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-5.2-CFLAGS.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage unittest || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
python_install_all() {
local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )