summaryrefslogtreecommitdiff
path: root/dev-python/pygresql/pygresql-5.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygresql/pygresql-5.2.2.ebuild')
-rw-r--r--dev-python/pygresql/pygresql-5.2.2.ebuild28
1 files changed, 25 insertions, 3 deletions
diff --git a/dev-python/pygresql/pygresql-5.2.2.ebuild b/dev-python/pygresql/pygresql-5.2.2.ebuild
index 578b5884f409..cf922e7456c7 100644
--- a/dev-python/pygresql/pygresql-5.2.2.ebuild
+++ b/dev-python/pygresql/pygresql-5.2.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
POSTGRES_COMPAT=( 9.6 {10..13} )
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 postgres
@@ -13,6 +13,7 @@ MY_P="PyGreSQL-${PV}"
DESCRIPTION="A Python interface for the PostgreSQL database"
HOMEPAGE="https://pygresql.org/"
SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="POSTGRESQL"
SLOT="0"
@@ -21,8 +22,29 @@ KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ~sparc x86"
DEPEND="${POSTGRES_DEP}"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-5.2-CFLAGS.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage unittest || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
python_install_all() {
local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )