summaryrefslogtreecommitdiff
path: root/dev-python/pyenchant/pyenchant-1.6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyenchant/pyenchant-1.6.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyenchant/pyenchant-1.6.6.ebuild')
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyenchant/pyenchant-1.6.6.ebuild b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
new file mode 100644
index 000000000000..d1be637659cd
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net https://pypi.org/project/pyenchant/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND=">=app-text/enchant-${PV%.*}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ esetup.py test
+ fi
+}