summaryrefslogtreecommitdiff
path: root/dev-python/pyenchant
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyenchant
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyenchant')
-rw-r--r--dev-python/pyenchant/Manifest5
-rw-r--r--dev-python/pyenchant/metadata.xml20
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.6.ebuild29
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.8.ebuild29
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyenchant/Manifest b/dev-python/pyenchant/Manifest
new file mode 100644
index 000000000000..4edc7fa3099e
--- /dev/null
+++ b/dev-python/pyenchant/Manifest
@@ -0,0 +1,5 @@
+DIST pyenchant-1.6.6.tar.gz 64010 BLAKE2B cdd0878ca58e05d955bf7d5518de71c02f663a8b00b1437bed8171fcdd08768691a9f9bc2bea0de0e942c2197bc9cbef66a88a114c47df3265c8d8034c95225a SHA512 af6aa1ac77b5718ec4b4aad3d0b88d26e697b472ec8261b23b37fdbf6b399a120ccc3e4ee6579b884c44b0eeb3f95bcdbceea189105c05088a48400a0c8cdb90
+DIST pyenchant-1.6.8.tar.gz 63693 BLAKE2B 5a8f867f3f40e81ec7d2431b678f324619b81942c8ca05a0cddc5acd2a3c645227fe6584b2236cfd440104f552d23786fff064d39762eb62e9e6a9d62ef1c670 SHA512 1a297cd279a0fbea2657bb42f2018a693b7f1d2da420f8cba436f680fb803282432f86e244a098eb7b9ef801059a3ee3c3bbaa748d30ea6357edf9f778e2f0a0
+EBUILD pyenchant-1.6.6.ebuild 751 BLAKE2B 0e79d6b7a81fb512af2700cae7e99592ab5012e6b3d6ab8ec1d480cd163b50ed0b71f9b78aa0aec2b83b0b7cdcb0bc68e8275af77ecb4037e75782c786ae8a7e SHA512 5ecd971fd492c5e039d250990abb2d7ee1d733491d4fe36af9120908a22cd2d156af8e98ac939ae8b9899955f3fe308240f0575f490930932e7991b095f9e6b7
+EBUILD pyenchant-1.6.8.ebuild 758 BLAKE2B 2945e7e92eb83a3d09bd14b22ec3cb955ecb5d2609de72aadb091fa21915f26357e678865a6f76610bcb019e384e3bd0c5bd9da00adb1fa25b6cd0740000cc20 SHA512 a3de5f9ad29b27cd32ca4bef94e20fb725bf0938eb1b2ff65a460d4480cff25c0871bd37cc24688b138c4e53c2416d781a0e53e401deeba63e1626ad131c792a
+MISC metadata.xml 817 BLAKE2B a4ea16f5a872477cbe84e1aad65d6705e68aa3226358618ad3449a0eff7de175ad6953283f7407d07fb13e9f3cde7c9c23865654ff0c859615f567e42782c7ac SHA512 3af25ba667f443ffc1c5852986b499689d16b20e82867724112cb9c0869b7c6a684e8f4dbd9354e89c721e350ca6ba3fea4f3abb110b8613779060233adc22c3
diff --git a/dev-python/pyenchant/metadata.xml b/dev-python/pyenchant/metadata.xml
new file mode 100644
index 000000000000..016b0abca652
--- /dev/null
+++ b/dev-python/pyenchant/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyEnchant is a set of language bindings and some wrapper classes to
+ make the excellent Enchant spellchecker available as a Python
+ module. The bindings are generated using SWIG. It includes all the
+ functionality of Enchant with the flexibility of Python and a nice
+ 'Pythonic' object-oriented interface. It also aims to provide some
+ higher-level functionality than is available in the C API.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyenchant</remote-id>
+ <remote-id type="sourceforge">pyenchant</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyenchant/pyenchant-1.6.6.ebuild b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
new file mode 100644
index 000000000000..d1be637659cd
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net https://pypi.org/project/pyenchant/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND=">=app-text/enchant-${PV%.*}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ esetup.py test
+ fi
+}
diff --git a/dev-python/pyenchant/pyenchant-1.6.8.ebuild b/dev-python/pyenchant/pyenchant-1.6.8.ebuild
new file mode 100644
index 000000000000..231416986750
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net https://pypi.org/project/pyenchant/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=app-text/enchant-${PV%.*}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ esetup.py test
+ fi
+}