summaryrefslogtreecommitdiff
path: root/dev-python/pycurl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pycurl
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest4
-rw-r--r--dev-python/pycurl/pycurl-7.44.1-r1.ebuild (renamed from dev-python/pycurl/pycurl-7.44.1.ebuild)41
-rw-r--r--dev-python/pycurl/pycurl-7.45.1.ebuild93
3 files changed, 123 insertions, 15 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 1c6d6a9619a6..06b160940da7 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,4 +1,6 @@
AUX 7.44-fix-tests.patch 1679 BLAKE2B ca0126a6dc12203ba8409c70ffa5142288bc94fd07ccc4404ee6f19a8515a46cc4e257dd26a12266aa3263e359e9167daa3ef36bde9867d2a4346ce38fcaac1b SHA512 743fbc3335daccb4e1d21b4c0e659d87582120b21d1cacecf0725fed9fe1eb6251761fdb50814c04e79ac3b13408335b34072e94bc704d3c333b96eaa9d52f76
DIST pycurl-7.44.1.tar.gz 227562 BLAKE2B 7dcbde563140f28382768b89b95422f873d5396a1f050dfcd3686d87b0ca2c3f3871281ed87b1dfbe7e4268728c2ec3ba7a76e7d7ef57754af5c185bf2a6fbe8 SHA512 e251db332791de07364695b5fd59b3a290486eabbde8be9914b5edeefa8702b4dd9ab678739ad765f76ededeb7192444fefe2a076d3977f454259dfd06731059
-EBUILD pycurl-7.44.1.ebuild 2567 BLAKE2B 466bf05ee32f22414003634b550e0fc137b7b12a48771a99ece9382835ce55500c36c6ae9726fc3b8a326f6e14ed82e6be18d40f516b26a8aa15bc23572ca5d6 SHA512 5da6e47330010c905f5c71b6f2af3eed23cf811272fc6d2556c39e1e4f97d788828ce47728f1c4fb68e116f4dc1b4f262e31a4be7c0f760312a7306621ade7ab
+DIST pycurl-7.45.1.tar.gz 233879 BLAKE2B 8a6fe72f00cfd172b4f5e257f4526c4115047aa911d7fb3802d3bf105ac70dc866b27fa4878aae9f92229a5dd5108a2b5e1c9acfe93e1a94dac60d9405c5d5e6 SHA512 05639d484aac6d6688677589e391975158c5ef778456a47df575ad13fb8bd0db67ff8f5a39bdd99d82a67926aca421c01e687eec9d4fd87f32822b492b429635
+EBUILD pycurl-7.44.1-r1.ebuild 2598 BLAKE2B 633630a72681052118b90decdec88c4dc89d3f732099a51aef2fafae6f2559841e263c9b284e746cc067b55e847e56c1973949f1b07d9b83689d627b673a6f89 SHA512 8a24ade216d126828771c3134365624eb593514041df26feb157c3fdc66fca1af47a8f149614fab3fcbb9233e531d003bbeb0f9b1b5ab1e5f082ae757579271b
+EBUILD pycurl-7.45.1.ebuild 2576 BLAKE2B 0ebfbc982170ac686f98b095fb0339ffb1a3e64bb83d7be26c8f6c81ab64a748058278b4f874e2f87dc4e7c94054620e6ef3dc6ae7795c0401abfb30f9befbad SHA512 f8a27a8b42a3f481c82b631aa645dc180b32d0ef1845712689404cf9be2070148a28a8ab38ff394b1c920c8d789852125b9d338dd4d8c0d0599941755f67d024
MISC metadata.xml 1100 BLAKE2B dfc7fe054c7cc34c61bf58fef0378df304a539c28cbc0dff4ffff65ccc8892c38aaf1e275885fc54d2854d9acc6b382947038041f815b5941859be7cfe75523f SHA512 f1de0dccd625ae0b02ff9a55cbc1bbf7944faa24dba28ffd711c728001f180afa598a255132aea860ad616637325cdc653577af531b1a954a3994e8902c774aa
diff --git a/dev-python/pycurl/pycurl-7.44.1.ebuild b/dev-python/pycurl/pycurl-7.44.1-r1.ebuild
index 36650ec2f074..972d883b082a 100644
--- a/dev-python/pycurl/pycurl-7.44.1.ebuild
+++ b/dev-python/pycurl/pycurl-7.44.1-r1.ebuild
@@ -3,14 +3,17 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1 toolchain-funcs
DESCRIPTION="python binding for curl/libcurl"
HOMEPAGE="
- https://github.com/pycurl/pycurl
+ http://pycurl.io/
+ https://github.com/pycurl/pycurl/
https://pypi.org/project/pycurl/
- http://pycurl.io/"
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -25,29 +28,32 @@ RESTRICT="!test? ( test )"
# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
# does not need to initialize gcrypt threading and we do not need to
# explicitly link to libgcrypt.
-RDEPEND="
+DEPEND="
>=net-misc/curl-7.25.0-r1:=[ssl=]
ssl? (
net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
curl_ssl_openssl? ( dev-libs/openssl:= )
- )"
+ )
+"
-# bottle-0.12.7: https://github.com/pycurl/pycurl/issues/180
-# bottle-0.12.7: https://github.com/defnull/bottle/commit/f35197e2a18de1672831a70a163fcfd38327a802
-DEPEND="${RDEPEND}
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
test? (
- dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
- >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
- )"
+ )
+"
PATCHES=(
"${FILESDIR}/7.44-fix-tests.patch"
)
+distutils_enable_tests pytest
+
python_prepare_all() {
# docs installed into the wrong directory
sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
@@ -70,8 +76,15 @@ src_test() {
}
python_test() {
- nosetests -a '!standalone,!gssapi' -v --with-flaky || die "Tests fail with ${EPYTHON}"
- nosetests -a 'standalone' -v --with-flaky || die "Tests fail with ${EPYTHON}"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # refcounting tests are unreliable
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_readdata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writedata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writeheader_refcounting
+ )
+
+ epytest -p flaky tests
}
python_install_all() {
diff --git a/dev-python/pycurl/pycurl-7.45.1.ebuild b/dev-python/pycurl/pycurl-7.45.1.ebuild
new file mode 100644
index 000000000000..4572acaf3850
--- /dev/null
+++ b/dev-python/pycurl/pycurl-7.45.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Python bindings for curl/libcurl"
+HOMEPAGE="
+ http://pycurl.io/
+ https://github.com/pycurl/pycurl/
+ https://pypi.org/project/pycurl/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl examples ssl"
+
+# Depend on a curl with curl_ssl_* USE flags.
+# libcurl must not be using an ssl backend we do not support.
+# If the libcurl ssl backend changes pycurl should be recompiled.
+# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
+# does not need to initialize gcrypt threading and we do not need to
+# explicitly link to libgcrypt.
+DEPEND="
+ >=net-misc/curl-7.25.0-r1:=[ssl=]
+ ssl? (
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
+ curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
+ curl_ssl_openssl? ( dev-libs/openssl:= )
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/7.44-fix-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # docs installed into the wrong directory
+ sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
+ # TODO
+ sed -e 's:test_socks5_gssapi_nec_setopt:_&:' \
+ -i tests/option_constants_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # Override faulty detection in setup.py, bug #510974.
+ export PYCURL_SSL_LIBRARY=${CURL_SSL}
+}
+
+src_test() {
+ emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # refcounting tests are unreliable
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_readdata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writedata_refcounting
+ tests/memory_mgmt_test.py::MemoryMgmtTest::test_writeheader_refcounting
+ )
+
+ epytest -p flaky tests
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}