summaryrefslogtreecommitdiff
path: root/dev-python/pycurl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pycurl
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest3
-rw-r--r--dev-python/pycurl/files/7.44-fix-tests.patch34
-rw-r--r--dev-python/pycurl/pycurl-7.44.1.ebuild8
3 files changed, 42 insertions, 3 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index fdba082adcf7..1c6d6a9619a6 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,3 +1,4 @@
+AUX 7.44-fix-tests.patch 1679 BLAKE2B ca0126a6dc12203ba8409c70ffa5142288bc94fd07ccc4404ee6f19a8515a46cc4e257dd26a12266aa3263e359e9167daa3ef36bde9867d2a4346ce38fcaac1b SHA512 743fbc3335daccb4e1d21b4c0e659d87582120b21d1cacecf0725fed9fe1eb6251761fdb50814c04e79ac3b13408335b34072e94bc704d3c333b96eaa9d52f76
DIST pycurl-7.44.1.tar.gz 227562 BLAKE2B 7dcbde563140f28382768b89b95422f873d5396a1f050dfcd3686d87b0ca2c3f3871281ed87b1dfbe7e4268728c2ec3ba7a76e7d7ef57754af5c185bf2a6fbe8 SHA512 e251db332791de07364695b5fd59b3a290486eabbde8be9914b5edeefa8702b4dd9ab678739ad765f76ededeb7192444fefe2a076d3977f454259dfd06731059
-EBUILD pycurl-7.44.1.ebuild 2511 BLAKE2B c349a8028162b7d8857b754c0d9464283f34870ed83625dbd9914e60a91a990c88c61c3bf50f09c4c5bd6764fe17c6d4922d9090150b8188529f09d19cf7d3b2 SHA512 38d116b1b1ab6268de519edc9223ba118ce4dc5d5da50d8391b1a2c0edadf9e4e97800c7e71cbf9c991f009e9f98e8cf3fe61988e525b320b4a6c5a30b77198c
+EBUILD pycurl-7.44.1.ebuild 2567 BLAKE2B 466bf05ee32f22414003634b550e0fc137b7b12a48771a99ece9382835ce55500c36c6ae9726fc3b8a326f6e14ed82e6be18d40f516b26a8aa15bc23572ca5d6 SHA512 5da6e47330010c905f5c71b6f2af3eed23cf811272fc6d2556c39e1e4f97d788828ce47728f1c4fb68e116f4dc1b4f262e31a4be7c0f760312a7306621ade7ab
MISC metadata.xml 1100 BLAKE2B dfc7fe054c7cc34c61bf58fef0378df304a539c28cbc0dff4ffff65ccc8892c38aaf1e275885fc54d2854d9acc6b382947038041f815b5941859be7cfe75523f SHA512 f1de0dccd625ae0b02ff9a55cbc1bbf7944faa24dba28ffd711c728001f180afa598a255132aea860ad616637325cdc653577af531b1a954a3994e8902c774aa
diff --git a/dev-python/pycurl/files/7.44-fix-tests.patch b/dev-python/pycurl/files/7.44-fix-tests.patch
new file mode 100644
index 000000000000..d5d900100086
--- /dev/null
+++ b/dev-python/pycurl/files/7.44-fix-tests.patch
@@ -0,0 +1,34 @@
+https://github.com/pycurl/pycurl/commit/d47c68b1364f8a1a45ab8c584c291d44b762f7b1
+From: Samuel Henrique <samueloph@debian.org>
+Date: Sat, 30 Apr 2022 23:02:34 +0100
+Subject: [PATCH] tests: fix error message on error_test (for curl >= 7.83)
+
+curl 7.83.0 removed exclamation marks from a few error messages, curl commit:
+https://github.com/curl/curl/commit/6968fb9d54dc3a1aaa1b16088f038eaf5dd8b2d7
+
+This commit adds support for the new curl release while also supporting the previous ones.
+--- a/tests/error_test.py
++++ b/tests/error_test.py
+@@ -29,7 +29,8 @@ def test_pycurl_error_libcurl(self):
+ err, msg = exc.args
+ self.assertEqual(pycurl.E_URL_MALFORMAT, err)
+ # possibly fragile
+- self.assertEqual('No URL set!', msg)
++ # curl < 7.83.0 has an exclamation mark in this error message
++ self.assertIn(msg, ['No URL set!', 'No URL set'])
+ else:
+ self.fail('Expected pycurl.error to be raised')
+
+@@ -43,9 +44,10 @@ def test_pycurl_errstr_type(self):
+ self.curl.perform()
+ except pycurl.error:
+ # might be fragile
+- self.assertEqual('No URL set!', self.curl.errstr())
++ # curl < 7.83.0 has an exclamation mark in this error message
++ self.assertIn(self.curl.errstr(), ['No URL set!', 'No URL set'])
+ # repeated checks do not clear value
+- self.assertEqual('No URL set!', self.curl.errstr())
++ self.assertIn(self.curl.errstr(), ['No URL set!', 'No URL set'])
+ # check the type - on all python versions
+ self.assertEqual(str, type(self.curl.errstr()))
+ else:
diff --git a/dev-python/pycurl/pycurl-7.44.1.ebuild b/dev-python/pycurl/pycurl-7.44.1.ebuild
index 92d80f17d663..36650ec2f074 100644
--- a/dev-python/pycurl/pycurl-7.44.1.ebuild
+++ b/dev-python/pycurl/pycurl-7.44.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl examples ssl test"
RESTRICT="!test? ( test )"
@@ -44,6 +44,10 @@ DEPEND="${RDEPEND}
>=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/7.44-fix-tests.patch"
+)
+
python_prepare_all() {
# docs installed into the wrong directory
sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die