summaryrefslogtreecommitdiff
path: root/dev-python/pycparser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-31 08:14:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-03-31 08:14:00 +0100
commitdaefc1fa8bdde1007636967d93ee4db90d338818 (patch)
tree2c9f19ecbc1c84f2638b7e947ddb513d9e39a8cd /dev-python/pycparser
parent95f4ecedd41206e678e2ddec24f8382ba2287dd1 (diff)
gentoo auto-resync : 31:03:2024 - 08:14:00
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/Manifest2
-rw-r--r--dev-python/pycparser/pycparser-2.22.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index 61ab814cf99c..01d41081bee3 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,4 +1,6 @@
AUX pycparser-2.21-lextab-cache.patch 2535 BLAKE2B b0455189f1d64a18655cc43b969e260291acc0812c219490f8592bfc96d7f0653dc9b439acc8fef24e49e560ca3fca28e5b8734ec48fe8a6d9e981e239feafb6 SHA512 d24d3db2dae05e9bc4c76bae0dc1070c0905af239b6585d93da0d026e02ba609df28577c47f88ee33cb6c26c59abc5cdb73f806360cc964e5e834c96b55cf423
DIST pycparser-2.21.tar.gz 170877 BLAKE2B ae6bf42dfc552bf1e3bfb5430cdb0c15b5e011ec53cbd03e0e2507c08a1a78690cefce2de134bd984caccc5dbde90661cb4c18df5c289217967213aac4d52404 SHA512 e61fbdde484d1cf74d4b27bdde40cf2da4b7028ca8ecd37c83d77473dab707d457321aecaf97da3b114c1d58a4eb200290b76f9c958044b57e5fed949895b5f0
+DIST pycparser-2.22.tar.gz 172736 BLAKE2B a080df68cf114c355949b2911a80e89ed02a64b8d1d03e3c5807222249e5dfd2491f691962885dbadcdaf323b55a05c5597319ac082dcf6c67a9ac952be9a7e2 SHA512 c9a81c78d87162f71281a32a076b279f4f7f2e17253fe14c89c6db5f9b3554a6563ff700c385549a8b51ef8832f99f7bb4ac07f22754c7c475dd91feeb0cf87f
EBUILD pycparser-2.21-r2.ebuild 1958 BLAKE2B 98c8a08c5be434bf59c57cbe49cb3b9a88445c3c88146db37b4dae42751f879d4b23f07cef32e19c5c6946ea17c5ad30d49f0f82ecc9afa5601c569fe1d392a7 SHA512 50871bb5b0d56bf2e6cbbb35a30b5ecebb2b6ff5de7ac60a136280d0b27214be1e80acf87b862cdd85d6583246bd730c9171479b24ba52581131ed651b5384e4
+EBUILD pycparser-2.22.ebuild 1856 BLAKE2B 200c558198f9eb4faaeef7a5d3e6e96bcd4581ee3697a23f6badd4c90f7519fd3ea0f638ee39432e2b57fdce083e60d10395018fd7a03fc2ee7dc1ac718c8e46 SHA512 1abd0f0edfbf4a3445596ed2b37727ce31aa9ec9908ca240842befcd8d39f306459e66c41062f9a4adc2a6fcc3b7fd4b49fcffc435c899d2c46a3c2bde4fe92f
MISC metadata.xml 406 BLAKE2B 61cb250ac460c4ea05f47bd8d208e44706bc80965ca1982e490d759d3a63652e5e13bf357532afb599ecea491f3c9a4cd315b97250b115bb7e8fa769b2ef03ff SHA512 b2d4ffde31f97a98e4a74bdd70751519d1339bbf3384e9e671760506fc2dac9d92bf6f7a743973002b4ae6da1cd2bb11abbfe63cbb330a1c32702b3eef24a62b
diff --git a/dev-python/pycparser/pycparser-2.22.ebuild b/dev-python/pycparser/pycparser-2.22.ebuild
new file mode 100644
index 000000000000..c0a56673a0df
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.22.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="
+ https://github.com/eliben/pycparser/
+ https://pypi.org/project/pycparser/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-python/ply:=[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ # Ensure we can find tests in our directory
+ sed -i -e 's/from tests.test_util/from test_util/g' tests/test_*.py || die
+
+ # unbundle ply
+ rm -r pycparser/ply || die
+ sed -i -e 's:\(from \)[.]\(ply\b\):\1\2:' pycparser/*.py || die
+ sed -i -e "s:'pycparser.ply'::" setup.py || die
+
+ ln -s "${S}"/examples tests/examples || die
+
+ rm tests/test_examples.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Skip tests if cpp is not in PATH
+ type -P cpp >/dev/null || return 0
+ # change workdir to avoid '.' import
+ cd tests || die
+
+ # Ensure that 'cpp' is called with the right arguments
+ # Tests don't seem to always pass the include they intend to use.
+ mkdir -p "${T}"/bin || die
+ cat > "${T}"/bin/cpp <<-EOF || die
+ #!${BROOT}/bin/bash
+ exec ${BROOT}/usr/bin/cpp -I${S}/utils/fake_libc_include/ \$@
+ EOF
+ chmod +x "${T}"/bin/cpp || die
+
+ PATH="${T}/bin:${PATH}" eunittest
+}