summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-31 08:14:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-03-31 08:14:00 +0100
commitdaefc1fa8bdde1007636967d93ee4db90d338818 (patch)
tree2c9f19ecbc1c84f2638b7e947ddb513d9e39a8cd /dev-python
parent95f4ecedd41206e678e2ddec24f8382ba2287dd1 (diff)
gentoo auto-resync : 31:03:2024 - 08:14:00
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin271258 -> 271258 bytes
-rw-r--r--dev-python/apprise/Manifest2
-rw-r--r--dev-python/apprise/apprise-1.7.5.ebuild38
-rw-r--r--dev-python/cython/Manifest2
-rw-r--r--dev-python/cython/cython-3.0.10.ebuild84
-rw-r--r--dev-python/numpy/Manifest2
-rw-r--r--dev-python/numpy/numpy-2.0.0_rc1.ebuild169
-rw-r--r--dev-python/pycparser/Manifest2
-rw-r--r--dev-python/pycparser/pycparser-2.22.ebuild69
-rw-r--r--dev-python/recurring-ical-events/Manifest4
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild (renamed from dev-python/recurring-ical-events/recurring-ical-events-2.1.2.ebuild)2
-rw-r--r--dev-python/types-docutils/Manifest2
-rw-r--r--dev-python/types-docutils/types-docutils-0.20.0.20240331.ebuild17
13 files changed, 390 insertions, 3 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 78b64fae73d2..da9aa47608c1 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 4ef8b7772107..2eed82eb142b 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,3 +1,5 @@
DIST apprise-1.7.4.tar.gz 1648673 BLAKE2B 33c91a63e3d0e730dcfe2b99433cd97e16ff9635e9ff717e9c4f7b708e6536185265e591ff419a785044877cadd4793f2df73fe9420ffed65838fb16654810f8 SHA512 5e3ab2136f1bdbd9d769fb3e3c5a5c899834b7ffb6ba57f3601079d516e31bed9d988b76745c251fff6df91f1fcd186d23a0878165ad73b811f76a8118278a64
+DIST apprise-1.7.5.tar.gz 1652098 BLAKE2B 01acc8be50b76cdcb5c7ce068b6f644d5edbbf28ea964d95e8d2ea0579a3a9c60e9715ae482ec0d7f16f4ce8118acf99e4159249bc763f268f89362a3e4fcde9 SHA512 d783d74a8e4a9f9b39c2ab86c0207a99e6f5fe30492b5bc50cb7008477acc1c5831d94c18bd3cee22fa28e028571108237191cc7a253aa072e121cecd0ce7afa
EBUILD apprise-1.7.4.ebuild 894 BLAKE2B e856be36348ff265cb46650bc374d9a227b251d28384f5b0215daff87754c38365e56a683a75b5791ece4a724a6780da1df91b40a93bb61a18cfa5e6ea46822f SHA512 7e5193bd302bdc105a620c07a0dba4ee1df20af98e745472d43979f4fd6ec1a8c29172e050327165bcf788d3315f3f9546fbe7d1497d0cc226cfd7aec98dbc0f
+EBUILD apprise-1.7.5.ebuild 895 BLAKE2B c00ba1868a8bf8f8cedffbf3ff816b35ca67476e955b7083571a06b690012e8a999d74b5518d83885fa5d2b2937100a2370cff66530e760cfb9818aed463ef49 SHA512 8604514dcf11353158f08e2ad60191b0cc5eb52e7124c9f8e2a967fc4c284ca5f7b73b56b4d6a6d4bdeb02ac197b10116bd0ecdf24ea2152800476399a3ddfe8
MISC metadata.xml 660 BLAKE2B e5d3535632acf00f228e96b2deca73aca518faf9f9e3ec032e13fdea4480e3f83791b3846e456ae47a917a3462c47882358c3ea1c69d20b6332a6ade65340211 SHA512 4c69871bdd771b7cc1af57e018ed1cc1f2194bdf2f7c1e750433911cf75e45f8fa4aa82df71255ce0a1c949db9d220ed614d5932ccf1ff5e78976bec482751a6
diff --git a/dev-python/apprise/apprise-1.7.5.ebuild b/dev-python/apprise/apprise-1.7.5.ebuild
new file mode 100644
index 000000000000..a85837c32c40
--- /dev/null
+++ b/dev-python/apprise/apprise-1.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index 5d2e79434ffa..f1ff0396fd35 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,8 +1,10 @@
AUX cython-0.29.22-spawn-multiprocessing.patch 963 BLAKE2B ebbc3f6f4fa88e7e082326bccbad328724a4ff5645f0b2aa28f21419044b17bed8495618bb980b23a99310c2b6ef275331e1b9aa6d734017eb33646c92a07a73 SHA512 3f5c6b4108b87cf3014416386095c07ac91762152bbd87e8bd589177d40b933c11e19610bea06720c5c70f76b5b9b70d27e5c3cfa20eed30deaaf7d122910bd3
AUX cython-0.29.23-pythran-parallel-install.patch 874 BLAKE2B 39286ee98427260ce6ec077a750e0a1412445343fd11be9d96d8ab65b7d9789c5f1864cb9a1b3565ee3f51e117ecc854ebacc39dc32917fc72f36340c2d7f0a1 SHA512 8b78755288d3f165d962a5a1be9492d609a8e3dab10197b271c84ed0c4b7006053038e68f18bbb4204e6acba83e3f72ffeabf57ffa03f4a08f28b65db3cfd854
AUX cython-0.29.23-test_exceptions-py310.patch 656 BLAKE2B 6c650c85d01b8bf367528d144cd967fa9def94634e35763e2e7a1c3e5afa2b01d0c84694024dde6e45577eee223f6464b5f88ab971d207d35892edf347a0c08f SHA512 d8f7f770a0b3303552deec0e7d3f9258de1edcd384f4b2c3881634fd21ce847a3d974e9142d1ed2fbe3a549e65292c6690be3a36ab4de52d0593d9831dc2f7ce
+DIST cython-3.0.10.gh.tar.gz 2771679 BLAKE2B f0813afc291bdc4940cd6770a368eca4f6d9fd728e41e9c341970512196154be900600146f98ce1e5a056eaeeda2df2a59fea2a9973c3ec275fe605bfd12e418 SHA512 97aa831cea96c1f3c51653c51fadb0aea8bdfdb076a2c898862637f52b826bcb9162d1b7aade3304c5650d0b894cb1083052f036365d79cd3d390e0486b33ac5
DIST cython-3.0.8.gh.tar.gz 2764668 BLAKE2B 03202ea480fa398d2b0893cc96185467009c783cf4451fc5d1c09ec229398bc084276680ed2b64acf63253744f827427e03674be3e5985d5a2912d9f338c786a SHA512 1070fc278401990595d177b0e6396bc1eba2ea8234a7c5bb26399b6b7284de7791ee5fa60ef74d06d0f4120b9c877bfd7703a7d701838f1634737526c614b860
DIST cython-3.0.9.gh.tar.gz 2769345 BLAKE2B 2a21b5e7060727d727902a08d7e038dacc047b724ebaa496ba5768542e28eec3c6198062ac3dd774a4321204752b373516f193f01bc6951e5f38b6029754647e SHA512 7899474882faab14716973783bbb46b981eab48192791acbbd06133efee83bfa9ace0e9a0272b0a44061a95ed94cdceaa98c4100f843220f5987791e36fa00e6
+EBUILD cython-3.0.10.ebuild 2009 BLAKE2B 6159bc912b9fabd81f3b9a75ea821fa2cdb91c91ca51a4850d254fe8a3ab707d9c3889bef25f26e3e68dd0a36fb210ee4b7f8028ed5563563b268eca8b77480f SHA512 55414c4e76597e8bf44f043fde72f09a9d5fb81a0e4bfce6424894dc61b07e8b6e8ff30d1b2ce6f8b1d646916da63cfd4a88a0fcef830154b1961f27bba32ca2
EBUILD cython-3.0.8.ebuild 1998 BLAKE2B a599920ea883b4c4f932df92871c528e72313c7ca6ea8027a58ab25ef3c4701aaf6cc9adaa9bcb68ce1e2677b9556e93f7f13de492321ea21f0f0455461a2c7b SHA512 d5c5757a4cd96ff52b0d6e1cb106c68ff42a2cdfe8470e1ad42e74e66f4fcdac39ce17fd9ca1e3a11ce15a07681eb5d3e13a6260cbc3cb012032581569859765
EBUILD cython-3.0.9.ebuild 1999 BLAKE2B 1f1efbf904b837248cb1003dc704e5866a0dc9f38818ce0a24b679358fbd4071bcab3d061bfbf4a5e927d81329bbe736c34093a0a36b7ef5423f7bf49bbb969d SHA512 1156bfc8d7d01604c8642cc55e013e983fed294001d194a4731c8024639049d7cb7e97f9f5da3da0d6b26206f7a7383b49fc4259e5612a0c7f7f8960645e62d7
MISC metadata.xml 606 BLAKE2B 1ee3fc75852383aa0618afeb7521c3ae0e95b518c85b2c58ff958905092cf68017d313a09d25031a50b649f9dd1b452e751036f2552df9d91447baaeff0a8f0b SHA512 b7917c2e417cee9e59c8011246f7223f5095c87f0294ea140dbfc8fda0b09cf61c9f055380a9d3f74a07e71bb49d75f219d6224ea95f1f4d4b451e5688c13f78
diff --git a/dev-python/cython/cython-3.0.10.ebuild b/dev-python/cython/cython-3.0.10.ebuild
new file mode 100644
index 000000000000..bc5b156b9db0
--- /dev/null
+++ b/dev-python/cython/cython-3.0.10.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 multiprocessing toolchain-funcs
+
+MY_P=${P/_rc/rc}
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="
+ https://cython.org/
+ https://github.com/cython/cython/
+ https://pypi.org/project/Cython/
+"
+SRC_URI="
+ https://github.com/cython/cython/archive/${PV/_rc/rc}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ <dev-python/numpy-2[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.29.22-spawn-multiprocessing.patch"
+ "${FILESDIR}/${PN}-0.29.23-test_exceptions-py310.patch"
+ "${FILESDIR}/${PN}-0.29.23-pythran-parallel-install.patch"
+)
+
+distutils_enable_sphinx docs \
+ dev-python/jinja \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+
+python_compile() {
+ # Python gets confused when it is in sys.path before build.
+ local -x PYTHONPATH=
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON} (xfail)"
+ return
+ fi
+
+ # Needed to avoid confusing cache tests
+ unset CYTHON_FORCE_REGEN
+
+ tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
+ "${PYTHON}" runtests.py \
+ -vv \
+ -j "$(makeopts_jobs)" \
+ --work-dir "${BUILD_DIR}"/tests \
+ --no-examples \
+ --no-code-style \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index dfe133908843..044f875ac904 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -4,9 +4,11 @@ DIST numpy-1.26.2.tar.gz 15664248 BLAKE2B 006e511e27c009f27bf4bf6c8c30c84a4bf0e8
DIST numpy-1.26.3.tar.gz 15679696 BLAKE2B 4c063e1a495b187049b5604686c0411b056fd03a69b5044cff10693694a7f055c87a017334cf8d05aa4a4cb87896fdf9203f51742d3cf83dbaf611b0e6e4091a SHA512 25556b41e2db9cfc52c1dfa61b05e4fc1b7b6df3b169f365375575d1146857fdb5ff91ca1508b968c296b7a06e5c6d95e82c41cdc3561587a46d3aa178f6305d
DIST numpy-1.26.4.tar.gz 15786129 BLAKE2B ee759d3a857111bc494d5e989a7b005375d942b2a89cda69be4a3bd7c6cb195003fd2a8a0535f1858d8977ff688b0ec36360dcba9c3160206eedce5e28f191ef SHA512 f7121ab4099fa0686f9c095d456baa4a5869d651d7b7a06385f885f329cf08f11024b5df5e7b4ee705970062a8102ec4f709512eabbfd5c9fccce4ef83b9c208
DIST numpy-2.0.0b1.tar.gz 18310319 BLAKE2B 62e3aee962f744bff4b3faa2427dbaa30d8012e76be383f3df5cd354a7d618cb6753940093413cb12928b971ee69d4f367e18e2c5c17cb41ee159d1f25540a99 SHA512 7072e64e954089df83384f45e2e5ac51ca647ab52a9552e7d2279a7d14853b3d17fb00ab33ed7c8c5987b87d33b44effa6e99c3e901209bcd8b16a2db539da45
+DIST numpy-2.0.0rc1.tar.gz 18314779 BLAKE2B 5f304986330356418302d755d2a94edabbb62b7d88f4637b9f3fa633925174a8d5044f686635ff97dc81a5b464f2a66246ef4c3ede12a2c0441778acd2380927 SHA512 1f3bef3fd51f074b137099921ab0bc0f1af46c9e27993f315b8a7af2cab948de9f91af341a6976d54fae099ba1aa9e0e917eecd520c3721c1ba8e17c28d40be8
EBUILD numpy-1.26.1.ebuild 4493 BLAKE2B 7f588777822396538c2004ce566575508aa65dae01afde32bfd40ac74955fbba98758d2cdaafbd51070b073bf216a528cc2c930970ed7de018b2def0e2b15722 SHA512 2e55c6c7e80864b031a834cbbe5862f608d9d77ddcfb6f868504951889e639f4d39bc1097c1d5a34a145d44511450de0fe38a3299de69d4f059c65b0456a9720
EBUILD numpy-1.26.2.ebuild 4769 BLAKE2B 0185c924c3348ab96eb83c2ec6d766994c0ea325c5d7287caa5a8e1cc3be6401b35eaf0bc5d6703e74f4ee8a4de6ef4e1514deae3ea904cf9b083aea7ed8da9a SHA512 d18013696e917b2a7841fc2bf6a122cf6ba400f1d109878ada6abee0640fd06fd91ab2480eb6b429e014891fa96cfab3c090964d149a6e3d1dd0859fc36aa041
EBUILD numpy-1.26.3.ebuild 4787 BLAKE2B 22d76498a5fe1340594347ec1780140b8d5e20a33fc74c04defe02365e16d3c82ecc2de8f3a9ed205aee754865ee7109003ad62eebac5d7c99f662729bef2c4f SHA512 829d0fa1472cfc0e509e091c5889d2eb1c0cdb132f329774d088d6ee4cbd4d44b209eb304fbb8e3716a7e284773b52a0247ca0187979fad38b6287d5b4c206f8
EBUILD numpy-1.26.4.ebuild 4789 BLAKE2B 61b429d317f69ad02e9abb6aa79ea0f5704115fa5d0771ea723f723fff7d0d807c9248ae54864bfbc2efb81ba9b92233e15f903641606d60c1a85f13d619abbf SHA512 19c54b7a33cbb0f7cc97de623424de4ece26b86337a7826fabee84615f9ceb2618b00463f7998c35ada16f9a9fe1e79d5fc61caa4ecd6293085d3a4d62d19697
EBUILD numpy-2.0.0_beta1.ebuild 4793 BLAKE2B eab1acf7b5d43149b3e259500c587b5ddccee1b676b84b8ebf648f07093c92eeb309b754a0dd994e32bd971228733a9052f333d3b50a624145ed975012a35002 SHA512 6fe9ccfb8cd8aa7c65e927bcae2692d638ec781496e213b6df3115848c87790cb1f6821d1bfc8b81ed95429586745af2e179f040db42b9eae57a58f5d5b714a9
+EBUILD numpy-2.0.0_rc1.ebuild 4793 BLAKE2B eab1acf7b5d43149b3e259500c587b5ddccee1b676b84b8ebf648f07093c92eeb309b754a0dd994e32bd971228733a9052f333d3b50a624145ed975012a35002 SHA512 6fe9ccfb8cd8aa7c65e927bcae2692d638ec781496e213b6df3115848c87790cb1f6821d1bfc8b81ed95429586745af2e179f040db42b9eae57a58f5d5b714a9
MISC metadata.xml 932 BLAKE2B 7a4af31f613bab05ff542da48bf6ff1484d9df2459f559516e71329451dd739d3df0fead507c8033d94ab9ed516b68efe7f21819a8cd6ca303643d8c8bc34e86 SHA512 32cb8c1ab61521a02cbec38f6ea383f074e50d46aa3462ddcb85710f9d348e8e628cf2a5725e3cd921cc32f02885a1b5f02125639f0ec885384eeeff7f468a06
diff --git a/dev-python/numpy/numpy-2.0.0_rc1.ebuild b/dev-python/numpy/numpy-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..ef4c58ca976f
--- /dev/null
+++ b/dev-python/numpy/numpy-2.0.0_rc1.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 flag-o-matic fortran-2 pypi toolchain-funcs
+
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="
+ https://numpy.org/
+ https://github.com/numpy/numpy/
+ https://pypi.org/project/numpy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+# +lapack because the internal fallbacks are pretty slow. Building without blas
+# is barely supported anyway, see bug #914358.
+IUSE="+lapack"
+if [[ ${PV} != *_[rab]* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+RDEPEND="
+ lapack? (
+ >=virtual/cblas-3.8
+ >=virtual/lapack-3.8
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-build/meson-1.1.0
+ >=dev-python/cython-3.0.6[${PYTHON_USEDEP}]
+ lapack? (
+ virtual/pkgconfig
+ )
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.14.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ -Dallow-noblas=$(usex !lapack true false)
+ -Dblas=$(usev lapack cblas)
+ -Dlapack=$(usev lapack lapack)
+ # TODO: cpu-* options
+ )
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Very disk-and-memory-hungry
+ lib/tests/test_io.py::TestSaveTxt::test_large_zip
+ lib/tests/test_io.py::TestSavezLoad::test_closing_fid
+ lib/tests/test_io.py::TestSavezLoad::test_closing_zipfile_after_load
+
+ # Precision problems
+ _core/tests/test_umath_accuracy.py::TestAccuracy::test_validate_transcendentals
+
+ # Runs the whole test suite recursively, that's just crazy
+ core/tests/test_mem_policy.py::test_new_policy
+
+ typing/tests/test_typing.py
+ # Uses huge amount of memory
+ core/tests/test_mem_overlap.py
+ 'core/tests/test_multiarray.py::TestDot::test_huge_vectordot[complex128]'
+
+ # TODO: crashes
+ lib/tests/test_histograms.py::TestHistogram::test_big_arrays
+
+ # likely a test problem
+ # https://github.com/numpy/numpy/issues/25135
+ core/tests/test_cython.py::test_conv_intp
+
+ # flaky
+ f2py/tests/test_crackfortran.py
+ f2py/tests/test_data.py::TestData{,F77}::test_crackedlines
+ )
+
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
+ # Degenerate case of arm32 chroot on arm64, bug #774108
+ EPYTEST_DESELECT+=(
+ core/tests/test_cpu_features.py::Test_ARM_Features::test_features
+ )
+ fi
+
+ if use x86 ; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/numpy/numpy/issues/18388
+ core/tests/test_umath.py::TestRemainder::test_float_remainder_overflow
+ # https://github.com/numpy/numpy/issues/18387
+ random/tests/test_generator_mt19937.py::TestRandomDist::test_pareto
+ # more precision problems
+ core/tests/test_einsum.py::TestEinsum::test_einsum_sums_int16
+ )
+ fi
+
+ if use hppa ; then
+ EPYTEST_DESELECT+=(
+ # TODO: Get selectedrealkind updated!
+ # bug #907228
+ # https://github.com/numpy/numpy/issues/3424 (https://github.com/numpy/numpy/issues/3424#issuecomment-412369029)
+ # https://github.com/numpy/numpy/pull/21785
+ f2py/tests/test_kind.py::TestKind::test_real
+ f2py/tests/test_kind.py::TestKind::test_quad_precision
+ )
+ fi
+
+ if [[ $(tc-endian) == "big" ]] ; then
+ # https://github.com/numpy/numpy/issues/11831 and bug #707116
+ EPYTEST_DESELECT+=(
+ 'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f77[s1]'
+ 'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f90[t1]'
+ 'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f90[s1]'
+ 'f2py/tests/test_return_character.py::TestFReturnCharacter::test_all_f77[t1]'
+ f2py/tests/test_kind.py::TestKind::test_int
+ )
+ fi
+
+ case "${ABI}" in
+ alpha|arm|hppa|m68k|o32|ppc|s390|sh|sparc|x86)
+ EPYTEST_DESELECT+=(
+ # too large for 32-bit platforms
+ core/tests/test_ufunc.py::TestUfunc::test_identityless_reduction_huge_array
+ 'core/tests/test_multiarray.py::TestDot::test_huge_vectordot[float64]'
+ 'core/tests/test_multiarray.py::TestDot::test_huge_vectordot[complex128]'
+ )
+ ;;
+ *)
+ ;;
+ esac
+
+ if ! has_version -b "~${CATEGORY}/${P}[${PYTHON_USEDEP}]" ; then
+ # depends on importing numpy.random from system namespace
+ EPYTEST_DESELECT+=(
+ 'random/tests/test_extending.py::test_cython'
+ )
+ fi
+
+ rm -rf numpy || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs numpy
+}
+
+python_install_all() {
+ local DOCS=( LICENSE.txt README.md THANKS.txt )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index 61ab814cf99c..01d41081bee3 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,4 +1,6 @@
AUX pycparser-2.21-lextab-cache.patch 2535 BLAKE2B b0455189f1d64a18655cc43b969e260291acc0812c219490f8592bfc96d7f0653dc9b439acc8fef24e49e560ca3fca28e5b8734ec48fe8a6d9e981e239feafb6 SHA512 d24d3db2dae05e9bc4c76bae0dc1070c0905af239b6585d93da0d026e02ba609df28577c47f88ee33cb6c26c59abc5cdb73f806360cc964e5e834c96b55cf423
DIST pycparser-2.21.tar.gz 170877 BLAKE2B ae6bf42dfc552bf1e3bfb5430cdb0c15b5e011ec53cbd03e0e2507c08a1a78690cefce2de134bd984caccc5dbde90661cb4c18df5c289217967213aac4d52404 SHA512 e61fbdde484d1cf74d4b27bdde40cf2da4b7028ca8ecd37c83d77473dab707d457321aecaf97da3b114c1d58a4eb200290b76f9c958044b57e5fed949895b5f0
+DIST pycparser-2.22.tar.gz 172736 BLAKE2B a080df68cf114c355949b2911a80e89ed02a64b8d1d03e3c5807222249e5dfd2491f691962885dbadcdaf323b55a05c5597319ac082dcf6c67a9ac952be9a7e2 SHA512 c9a81c78d87162f71281a32a076b279f4f7f2e17253fe14c89c6db5f9b3554a6563ff700c385549a8b51ef8832f99f7bb4ac07f22754c7c475dd91feeb0cf87f
EBUILD pycparser-2.21-r2.ebuild 1958 BLAKE2B 98c8a08c5be434bf59c57cbe49cb3b9a88445c3c88146db37b4dae42751f879d4b23f07cef32e19c5c6946ea17c5ad30d49f0f82ecc9afa5601c569fe1d392a7 SHA512 50871bb5b0d56bf2e6cbbb35a30b5ecebb2b6ff5de7ac60a136280d0b27214be1e80acf87b862cdd85d6583246bd730c9171479b24ba52581131ed651b5384e4
+EBUILD pycparser-2.22.ebuild 1856 BLAKE2B 200c558198f9eb4faaeef7a5d3e6e96bcd4581ee3697a23f6badd4c90f7519fd3ea0f638ee39432e2b57fdce083e60d10395018fd7a03fc2ee7dc1ac718c8e46 SHA512 1abd0f0edfbf4a3445596ed2b37727ce31aa9ec9908ca240842befcd8d39f306459e66c41062f9a4adc2a6fcc3b7fd4b49fcffc435c899d2c46a3c2bde4fe92f
MISC metadata.xml 406 BLAKE2B 61cb250ac460c4ea05f47bd8d208e44706bc80965ca1982e490d759d3a63652e5e13bf357532afb599ecea491f3c9a4cd315b97250b115bb7e8fa769b2ef03ff SHA512 b2d4ffde31f97a98e4a74bdd70751519d1339bbf3384e9e671760506fc2dac9d92bf6f7a743973002b4ae6da1cd2bb11abbfe63cbb330a1c32702b3eef24a62b
diff --git a/dev-python/pycparser/pycparser-2.22.ebuild b/dev-python/pycparser/pycparser-2.22.ebuild
new file mode 100644
index 000000000000..c0a56673a0df
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.22.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="
+ https://github.com/eliben/pycparser/
+ https://pypi.org/project/pycparser/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-python/ply:=[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ # Ensure we can find tests in our directory
+ sed -i -e 's/from tests.test_util/from test_util/g' tests/test_*.py || die
+
+ # unbundle ply
+ rm -r pycparser/ply || die
+ sed -i -e 's:\(from \)[.]\(ply\b\):\1\2:' pycparser/*.py || die
+ sed -i -e "s:'pycparser.ply'::" setup.py || die
+
+ ln -s "${S}"/examples tests/examples || die
+
+ rm tests/test_examples.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Skip tests if cpp is not in PATH
+ type -P cpp >/dev/null || return 0
+ # change workdir to avoid '.' import
+ cd tests || die
+
+ # Ensure that 'cpp' is called with the right arguments
+ # Tests don't seem to always pass the include they intend to use.
+ mkdir -p "${T}"/bin || die
+ cat > "${T}"/bin/cpp <<-EOF || die
+ #!${BROOT}/bin/bash
+ exec ${BROOT}/usr/bin/cpp -I${S}/utils/fake_libc_include/ \$@
+ EOF
+ chmod +x "${T}"/bin/cpp || die
+
+ PATH="${T}/bin:${PATH}" eunittest
+}
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index 36151c9eb31e..9c25a3506242 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1,5 +1,5 @@
-DIST python-recurring-ical-events-2.1.2.gh.tar.gz 328669 BLAKE2B 03bbae75a81526d855860c045711817200c1fca8a97574d324100a7d77c46f687ddb572d516a0bcddf90d629d9d9ff9bf7b2c868db5e6561447a1cd3b6b4f04b SHA512 42c11a211539cf6e40903f9df8224e8dd1dd68fe4894aa0ab1c2660c69a95d4cd1d9f41aa918d5180568f8ca3eecace0d5b845d669d7e532d61a7fa1f5283fd6
DIST python-recurring-ical-events-2.1.3.gh.tar.gz 329303 BLAKE2B c034fa558629bb8b3c6a901278d14a91826c3dfc805f6960936cd6dc1b219aff027615b05501c85767ab554112f6edf2a2467ced220bd92a7ac493673ca02ffe SHA512 1852b5ed09d1c531ac969aac338893e0409a54d6b0d59e15dbdcbe2a5f97f111c1c01272fa5df640d26c1a12fbc5f284e35c3e10aed0f16a842fe8a6a54462a7
-EBUILD recurring-ical-events-2.1.2.ebuild 1199 BLAKE2B 6e210be0896558017ea0624ce13998ccf3395b1f70280b90e13a191ec977336d509ff5ee996582db0d00766b64868d0aedf6e1441f1225ad7d2dfada9b0f06fa SHA512 91d91d9f71830b672acb6593247e613f1c25b2f21e95ae2ce5da466a0d00710c07df8ba508fc0bdeb4929e7fcc96c887e8cae55c9463bae86472d0911974ad76
+DIST python-recurring-ical-events-2.2.0.gh.tar.gz 332176 BLAKE2B 85eb127e4c8e505f21c135e9241353aee33ae9a5087fb0fb2c2bf9b6a0e913f36a5077569c76c3b92d196e506d8c2be83806a2f8e8554b957a7ee84a1145f316 SHA512 ba5a3b22728d73a392e071d0b1b5363ebf94f25dbe00728fe944d1c7dbb2998b90550756b3ac5e8c51ef310ee269b90f1345ac8380ab8a89bfb7b24f5797ae4c
EBUILD recurring-ical-events-2.1.3.ebuild 1204 BLAKE2B a59fc1eb92d2dd547358e92d275a8e58cd4b41f1f698ab0cfff66d36be55afb77b38f614edbdd58874802e7cf83021435fe2ec19c829d1c563d4a83852982fc8 SHA512 582a05386dd9c4844c10811bcf0610621e789779b76a1fcb1228173df7bc711cdb2ee561c33cb07e157894a1f571198ee28f6b9e1dfbe0d290dce3ee5306571e
+EBUILD recurring-ical-events-2.2.0.ebuild 1204 BLAKE2B a59fc1eb92d2dd547358e92d275a8e58cd4b41f1f698ab0cfff66d36be55afb77b38f614edbdd58874802e7cf83021435fe2ec19c829d1c563d4a83852982fc8 SHA512 582a05386dd9c4844c10811bcf0610621e789779b76a1fcb1228173df7bc711cdb2ee561c33cb07e157894a1f571198ee28f6b9e1dfbe0d290dce3ee5306571e
MISC metadata.xml 431 BLAKE2B 19ac0f0a385fb9b0524bf641831fbe3c02f35f3ada35922b297563f871cb8e745404e04d18d9f7428ef5b3cca27f5205f4a7f99e85e2a3da18542a19574f04de SHA512 35283cfbd447b3ec9d0d97ec7c11580db012ee60076b12ba733962d58896203a162ece04a9015eca8cc556f28fac307fc9ddeb27c3ea9cb9c8b2d6df0cf93a50
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.1.2.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild
index c790e2121364..b1d8fa71740b 100644
--- a/dev-python/recurring-ical-events/recurring-ical-events-2.1.2.ebuild
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
diff --git a/dev-python/types-docutils/Manifest b/dev-python/types-docutils/Manifest
index 51610ba1e4c7..c47fd03f8bba 100644
--- a/dev-python/types-docutils/Manifest
+++ b/dev-python/types-docutils/Manifest
@@ -1,3 +1,5 @@
DIST types-docutils-0.20.0.20240317.tar.gz 19250 BLAKE2B 8027b75cca44357b92c10e1c3543fb4624a62bd66862a4107a9e5e57db60dade31d1c25d7634a6417bba27d725fcca337c8159cb0bbec92f1823f84e249e0ebe SHA512 e7c32bcc7214be9e650f35a1b2cb019ff449e194bb74d3a087cba2a676240b741174541dd8c5d42c08bb734cc05a3789698b04de7dc87f897d9158ad769cc7aa
+DIST types-docutils-0.20.0.20240331.tar.gz 19359 BLAKE2B d72cb44a0815f07d19aa0b920556d59c29f567637cc89feed0b4d585001fa2f9b73e7ed5aa9edb308cc1915c8a7b3eb82899c58a437975130452451ff89a5dc4 SHA512 3f5bf1c5ea00c9ad1969fa539571a049706913164aed66868f9e634b5375580e023dfebc252397e6e8ff53246ca99f6d927d052c5a34ac7b34cbcfb47fd9a42a
EBUILD types-docutils-0.20.0.20240317.ebuild 374 BLAKE2B 4fef7d769f780f48dbe7c50c65f277035d8e07cbcf95e7a59c15d6ad49be6bc93098f12c1e84c73d6f68d9fefa9913726f07ec59969a7c368f4e376205c8d982 SHA512 49ee713f19131152e0aefc897c2c79d541fb9b46d367b20a3176a2b57307ebab295e51d3bb4d4a418fe3a674174e0498a06ef2e1e75be53779e0e55f19d9a2b3
+EBUILD types-docutils-0.20.0.20240331.ebuild 374 BLAKE2B 4fef7d769f780f48dbe7c50c65f277035d8e07cbcf95e7a59c15d6ad49be6bc93098f12c1e84c73d6f68d9fefa9913726f07ec59969a7c368f4e376205c8d982 SHA512 49ee713f19131152e0aefc897c2c79d541fb9b46d367b20a3176a2b57307ebab295e51d3bb4d4a418fe3a674174e0498a06ef2e1e75be53779e0e55f19d9a2b3
MISC metadata.xml 325 BLAKE2B 399aab1e8779e48d84998d6fdd595638aaf674b9a7076573aad7ade16855c4fc785dd45b1eff833c8ec7accda2a08cf561dfa14237e4edf6292fc7961ad76f7e SHA512 fb2768e73dd948c79654ab22c24d868a418576f2008153e45e4d0b42e2750872884bd35451ee3917203469d72d1c76f84d849e9d3534dc1006eb4d80b3ef04d7
diff --git a/dev-python/types-docutils/types-docutils-0.20.0.20240331.ebuild b/dev-python/types-docutils/types-docutils-0.20.0.20240331.ebuild
new file mode 100644
index 000000000000..cb335ec2836f
--- /dev/null
+++ b/dev-python/types-docutils/types-docutils-0.20.0.20240331.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Typing stubs for docutils"
+HOMEPAGE="https://pypi.org/project/types-docutils/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"