summaryrefslogtreecommitdiff
path: root/dev-python/pycairo/pycairo-1.23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /dev-python/pycairo/pycairo-1.23.0.ebuild
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'dev-python/pycairo/pycairo-1.23.0.ebuild')
-rw-r--r--dev-python/pycairo/pycairo-1.23.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pycairo/pycairo-1.23.0.ebuild b/dev-python/pycairo/pycairo-1.23.0.ebuild
new file mode 100644
index 000000000000..2c8700960b25
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.23.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="
+ https://www.cairographics.org/pycairo/
+ https://github.com/pygobject/pycairo/
+ https://pypi.org/project/pycairo/
+"
+SRC_URI="
+ https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg(+)]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ esetup.py build_tests
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}