summaryrefslogtreecommitdiff
path: root/dev-python/pycairo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /dev-python/pycairo
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest2
-rw-r--r--dev-python/pycairo/pycairo-1.23.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index 619345f701a4..b1ff274b33d6 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,5 +1,7 @@
DIST pycairo-1.21.0.tar.gz 340712 BLAKE2B 6578c75b478c14c641b5c0be44c3c633d32ecc09c4ef22a079024dd12b539d37f88efa6ce8aadb5a88a48b3cc793e573afe00eaa4e3ba563c3133cad72dacfe4 SHA512 0de226b05d0a358f3546e4a0d5bf342f124373718d4900c891a09c1ede11e3ed1fb9bee163c00acfc215044683ddf0b29c8573b7454f9c39f957a47d63c34baf
DIST pycairo-1.22.0.tar.gz 342295 BLAKE2B b331a627aea3b5fabaf9bbc089b5bb975178ea3be6383207ebefa994900dd73ff503309474729c9ce7b69e41c6495dd83a0db0d51410bea9aa37b30975e39700 SHA512 2a8da5b905536291291655a237fd0c6c54a5fe91a38296cffdc187c0c35837bd3176045f4ab39e59e7f67947deba7ba076c5e6ffdb46256b4b180c42267f41b6
+DIST pycairo-1.23.0.tar.gz 344623 BLAKE2B e0551e2d4259d509f3165682b11852f28f0df93e6befcd398ef95bc5f0eed0818dc72a05a9b085148d4369e9b3283bc4d91ce032c6c88a3b15962c83eb03db57 SHA512 fc0cc878cc716a6a2baf89a193facfcd89970c884afd3bb9d7fbecf42894ddd191988a8f0fe79100786509f17fbe4f1990eca33a5299414b2df2539d66de5abf
EBUILD pycairo-1.21.0-r1.ebuild 1122 BLAKE2B 088bb708641ab60be2133d13057bce3155dc8fa78a61cb0913f70a4a3dd638a31c73368915f076ac12f9f1062d15bae499aeb1447a711f3158a52f489ddb9353 SHA512 3f88ee9496d7b8036ce20e84a0c955e2c92d032f8c7c18c131bc95ab9cdaa0f0edbf8cc682e45824562537c00670b2ddff21858842234572861e36fa44c6ce15
EBUILD pycairo-1.22.0.ebuild 1184 BLAKE2B 39fd40fe16b66a55bffa0604c20df3ffa5bfb6386c22d2a2988571774d3e2669b0bdc509c299cb40784a3d2d7373dd8905b959b8f0b4fd6b3f1016c053862792 SHA512 6953dc63b7f06b72612cdc0f93f7440ce42387b336cc91ff68b08db169a70979c259d0a720d67e452060a0b76344a0208ae01bf3de60ab139a0c2f37a60ba257
+EBUILD pycairo-1.23.0.ebuild 1184 BLAKE2B 39fd40fe16b66a55bffa0604c20df3ffa5bfb6386c22d2a2988571774d3e2669b0bdc509c299cb40784a3d2d7373dd8905b959b8f0b4fd6b3f1016c053862792 SHA512 6953dc63b7f06b72612cdc0f93f7440ce42387b336cc91ff68b08db169a70979c259d0a720d67e452060a0b76344a0208ae01bf3de60ab139a0c2f37a60ba257
MISC metadata.xml 368 BLAKE2B 5e0f85e23bc56113927d28072c7178d27fc058b1e90851150c55e9e713edb96dd5daa79df8423f6719032538c9448d8afa9b750961bd82a5bcfae2d5e228c6b6 SHA512 c1e81ed2f535c8050f18950a57b71aa871b965c57d1e5ca8e8a4c48ecd643bc9ec326e046c1aea9f3f41124b9fe765a0b9b46a541c28f325cae7038cea66d086
diff --git a/dev-python/pycairo/pycairo-1.23.0.ebuild b/dev-python/pycairo/pycairo-1.23.0.ebuild
new file mode 100644
index 000000000000..2c8700960b25
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.23.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="
+ https://www.cairographics.org/pycairo/
+ https://github.com/pygobject/pycairo/
+ https://pypi.org/project/pycairo/
+"
+SRC_URI="
+ https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg(+)]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ esetup.py build_tests
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}