summaryrefslogtreecommitdiff
path: root/dev-python/pushbullet-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
commit20e7188871e6d724b707132f925b9872536a91a0 (patch)
tree1b8d527714db0a937011ad650939d9152d36506c /dev-python/pushbullet-py
parente4769acf6646f4b0ef28cb695cec8ed128aba920 (diff)
gentoo auto-resync : 15:12:2023 - 20:53:45
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/Manifest3
-rw-r--r--dev-python/pushbullet-py/metadata.xml13
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild50
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pushbullet-py/Manifest b/dev-python/pushbullet-py/Manifest
deleted file mode 100644
index 2fc233bb0b42..000000000000
--- a/dev-python/pushbullet-py/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pushbullet.py-0.12.0.tar.gz 23769 BLAKE2B 096c5995bee7dba65b7f385c2cbd70d839b22a07b26dd1ad9c1ef64244ba97e3c2f077c9eb0ca46a2ccd7df6a27e3ee3d4d55522986e832ca109d003e77fbad6 SHA512 5394fb8e8631ba00c610c36380e2c917231207ecd25bb4e2f1f0e44c232f4dd33b99ce5b1973467844b7f46f275ea812620e6549afd42915ee8fc13e1650f758
-EBUILD pushbullet-py-0.12.0-r1.ebuild 1056 BLAKE2B 8ff5a3ae3cc0b660d4efb29c0c99c4377110552512d69ae5044af891c11b22d8b6886a2170490b3a7239bfd7ec4ac2621b5286415e248362d187ff6c683f9748 SHA512 364fb4fdccdcc051fd9fa0d3483868f90dd5d90083d5b6491720e19a4f05e953feddb5893ce1cbfbe9953d5edb29ffc82a4030f2665775d9e2c9c1a50220e62a
-MISC metadata.xml 466 BLAKE2B f7555c99af2fd7fc2cdf9fa169dec8196f7e2241f3a6976fa934f7b8578e748231360dae27b115c0052178e57eca08bdfe37e36fbb6a9cdf5ea9fdb49077b7b2 SHA512 7e35666ae507b2fcdda81afb8297d0ed5eede47afd0620f699372f6b6df9f7965d86ef4cd66582f26dace6e013ac8916cf2eb31f4c3a62d61211918e4c25469b
diff --git a/dev-python/pushbullet-py/metadata.xml b/dev-python/pushbullet-py/metadata.xml
deleted file mode 100644
index 78a1ad74cd84..000000000000
--- a/dev-python/pushbullet-py/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>sbraz@gentoo.org</email>
- <name>Louis Sautier</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pushbullet.py</remote-id>
- <remote-id type="github">richard-better/pushbullet.py</remote-id>
- <bugs-to>https://github.com/richard-better/pushbullet.py/issues</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
deleted file mode 100644
index 20621dd4a6c7..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="
- https://github.com/richard-better/pushbullet.py/
- https://pypi.org/project/pushbullet.py/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Skip tests which require internet access
- PUSHBULLET_API_KEY= epytest -k "not (test_auth or test_decryption)"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}