summaryrefslogtreecommitdiff
path: root/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild')
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
deleted file mode 100644
index 20621dd4a6c7..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="
- https://github.com/richard-better/pushbullet.py/
- https://pypi.org/project/pushbullet.py/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Skip tests which require internet access
- PUSHBULLET_API_KEY= epytest -k "not (test_auth or test_decryption)"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}