summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
commit8d15cb8238a384acdb70250a0cd213f2ab5f0ab6 (patch)
tree547dd4d959be6b14e702d37e94063dc2104319a5 /dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild
parent71fb24e4cc15fe73651423df81c5e6a79fa8c142 (diff)
gentoo auto-resync : 23:02:2023 - 09:44:00
Diffstat (limited to 'dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild')
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild
new file mode 100644
index 000000000000..ca385c35243a
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest