summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
commit8d15cb8238a384acdb70250a0cd213f2ab5f0ab6 (patch)
tree547dd4d959be6b14e702d37e94063dc2104319a5 /dev-python/prompt-toolkit
parent71fb24e4cc15fe73651423df81c5e6a79fa8c142 (diff)
gentoo auto-resync : 23:02:2023 - 09:44:00
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest2
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
index 6a20408ceb87..f1f8e4b89c78 100644
--- a/dev-python/prompt-toolkit/Manifest
+++ b/dev-python/prompt-toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prompt_toolkit-3.0.36.tar.gz 423863 BLAKE2B 1917ba618e4111f3d2d85f1063e3e34bc47cc1f60e1703be54cf92b98f72eb3cb3062381e16fd324953435ed67ce0711274f6d8faf735bf966283cc2201f1b65 SHA512 db77a3acb8a985b1df3d82eca7ac30fbd5e85bf3bc77f0f6da13af8064a7d4dc9d7fd57be3eabe5eecce610c8220ad493d296f2e425a8f69d62fddd1e419af1e
+DIST prompt_toolkit-3.0.37.tar.gz 421637 BLAKE2B d8b0b8be846ff0ee9e35992d25e6153429a6d6316ea601f386c0cfeeec96119f9ddf109ca5a32e14a9ecae7badef808220722b5846cc984f2fd1dc7a18e3c763 SHA512 00e8b0d768c1449afd1c771a1b71611f291052ebed08c329cb9b34156588315b1d1202ac748293e6635c9ee78415068155565e69c2e632ae5513b61b670bd3fb
EBUILD prompt-toolkit-3.0.36.ebuild 591 BLAKE2B f4e92075df9579f2caa04ae4ee4d0e6394d570d364369c0ead7125c218a64bcc7f18eeaf457957f224d354716e7d77db89e2d5978a096f86a1ad1f70503f4e2d SHA512 9baa86bb79931ccd03922044dbd3d3690852f0bd1aa791cb67214395e33d5a5dfb85885ac9e94c0b219c43caec1aaefa51e9a731e58fc375c4da7870da749478
+EBUILD prompt-toolkit-3.0.37.ebuild 599 BLAKE2B 3917fe092acf7488340984ecc241334281fa85d902c1b0ae92f4c80563b9ebc5268772bcd4b90d4bb970d2e6fa06263f8d41b693fa29821ede8ef10c558b4cf9 SHA512 83788c3c76ffec70b4ad6b5c029921f16e6d8fd4f3e1434af6d7acaa06a4359ad54ef3e0e92295bcfb25cdfd2aa45f9d8ea2e9836bf56998aee4273cf48528b6
MISC metadata.xml 431 BLAKE2B 534336484c65b57df5e672729ff722b67445948e0485c3a62c2f7081724cb951b5157c600dc6162a3bb857c2be0f378b18670786279ff8b5cff2858588f8ebc9 SHA512 a9bf68326839069c61e70d4ef3fe304706f2543b9b91eb291566dd66f36d1abec00382ae205549a35f10dfc730f4613c5cc5c0ee4d6858538d50c4145bd3b15e
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild
new file mode 100644
index 000000000000..ca385c35243a
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.37.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest