summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild')
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
new file mode 100644
index 000000000000..9135bdefe03d
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_P=pyaml-${PV}
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P%-*}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" pyaml/tests/dump.py -v ||
+ die "tests failed under ${EPYTHON}"
+}