summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/pretty-yaml
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/pretty-yaml')
-rw-r--r--dev-python/pretty-yaml/Manifest4
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild2
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild31
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/pretty-yaml/Manifest b/dev-python/pretty-yaml/Manifest
index 119f3851dc34..707214004888 100644
--- a/dev-python/pretty-yaml/Manifest
+++ b/dev-python/pretty-yaml/Manifest
@@ -1,3 +1,5 @@
DIST pyaml-15.8.2.tar.gz 16544 BLAKE2B 1e9820c172bb0c2e05c78f5dee3299c6bb0d83e2c658f3cd45322abac3404af1c9dd1f3b00e2c7b285cbd00c17d382c82cbb16b96bbac10021a0ca1a008d0287 SHA512 74f1fdacdd601f0b6f710457627e4dcbc42e7301fe5faa061d3e8d593842d6e5dd85041625aba576bba9cda2a713ee07ca3067221a720cbddc6dcd417fccee64
-EBUILD pretty-yaml-15.8.2.ebuild 768 BLAKE2B 273155c63790512216c8c855fc0799fa6b631c247fb911ef11be91ffc6dd4520d39f20bc7fa3c55078c594e4c6aecb38af9659727bc3cfe9022abde2f5d5ccb9 SHA512 5c7de198ad72fceb84b2366266fadd56038377e42fa6b98c3eca91ecdd11d4826c4606c63e80aa94e16255ca3010216a223c220767495aabd337e9f78dd8aaa3
+DIST pyaml-20.4.0.tar.gz 21176 BLAKE2B 0aac0250d610d7b2ef042e251142de4520e7db96073d46bde0dcb37ad43d9c278cbdfc7ab247b4d41c7c30e893306aa47b25a584a2aa4c157d66203b8e140895 SHA512 432fd215e034beafc07270a6aa8b726d5a16ef8946a95c1db9a34b4f492bbe2089dffbb1ce856d3e8153ec18ac943973a23e3aa9283d53ee0b2e7ba5dcd3d317
+EBUILD pretty-yaml-15.8.2.ebuild 767 BLAKE2B d7d607bdbeef29d67ecff12eeae5482d241f52160f985994a5b588d62aa35142b0f01b1d7c13280d0d917297ef826f7a4be7f4ca6209ce4bb8e74e1569678266 SHA512 0831b756090da15e9169d107005838709a82c2de712bf2b3f0321ad839aed059f0fc703cfdc2a0ebb6cdbd51fbb94f6d06f08317b66df88e3ce327293f0116f2
+EBUILD pretty-yaml-20.4.0.ebuild 718 BLAKE2B 53b9721e44ab77f07e61301a711489633deff6830204b04760a2c83982e56694146be3f4bac05c5749824759e2932f8c1d1cc49c5767c82c56a2b821d4c9ff91 SHA512 295d7cd6914dc97c4846299d8d801849030f70ed45cefed81699583ebbefd316b3ccffa61bbd61b4080f95bd4513c2d73b4e6c5e44b48c28ac7c9e0410bb1eba
MISC metadata.xml 444 BLAKE2B 522c0c3698f3c35b698b255504afbcda02c321e542ba7013fb0e3de4f57334b31ee014dbfdc8914dd2760a621ab1724a9142029d506d8fa44831726ae7c2b6a9 SHA512 70aee75c33eaa54fc003d6879ada0d4fc772d00619273c7b0e7c5829dcffb8ba23171c563e6e922504d9256f53ee207b36b98240bec3d084a8e6de15e0013732
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
index b6ea020e3917..0a7759c45374 100644
--- a/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
+++ b/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
diff --git a/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
new file mode 100644
index 000000000000..9135bdefe03d
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_P=pyaml-${PV}
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P%-*}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" pyaml/tests/dump.py -v ||
+ die "tests failed under ${EPYTHON}"
+}