summaryrefslogtreecommitdiff
path: root/dev-python/plyvel/plyvel-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/plyvel/plyvel-1.0.5.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/plyvel/plyvel-1.0.5.ebuild')
-rw-r--r--dev-python/plyvel/plyvel-1.0.5.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/plyvel/plyvel-1.0.5.ebuild b/dev-python/plyvel/plyvel-1.0.5.ebuild
index 953e10d1c72d..8006345f9308 100644
--- a/dev-python/plyvel/plyvel-1.0.5.ebuild
+++ b/dev-python/plyvel/plyvel-1.0.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{6,7} )
inherit distutils-r1
@@ -28,12 +28,6 @@ DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-python_compile() {
- # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_compile_all() {
if use doc; then
sphinx-build doc doc/_build/html || die