summaryrefslogtreecommitdiff
path: root/dev-python/plyvel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/plyvel
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/plyvel')
-rw-r--r--dev-python/plyvel/Manifest4
-rw-r--r--dev-python/plyvel/plyvel-1.0.5.ebuild10
-rw-r--r--dev-python/plyvel/plyvel-1.1.0.ebuild10
3 files changed, 6 insertions, 18 deletions
diff --git a/dev-python/plyvel/Manifest b/dev-python/plyvel/Manifest
index c9546f3e1e37..304ec1afef1e 100644
--- a/dev-python/plyvel/Manifest
+++ b/dev-python/plyvel/Manifest
@@ -1,5 +1,5 @@
DIST plyvel-1.0.5.tar.gz 143728 BLAKE2B 2eac687e6901381b62df5278abe00684c8e5a9ac162596a1a1a0e620536155b5e5c0ba0ab9bb32c1d3a6467d997cfdf530e9275024f8caba3323728f3f3aba67 SHA512 d2a7fe9d49b377135ece03292f366423e9550d3440689a99246d8c5ddc38e474c2b05c709655c6bf74a1d04f742a23dfb8841b51698c2adb062418577b28c4b4
DIST plyvel-1.1.0.tar.gz 143970 BLAKE2B 980c8117f39c704abaf1733bfabb6816aa84e5e449ed37368038a7d6cd4cbbbf832319bf149ec6ae7cca5074984427df08afc50e033451d3d97ddafd210d91e0 SHA512 4d9b20f7e047d75af14d530519b4360194a18aa423a57ac4596441e47528bbc9f8e3ff763dd91da4c115cb1e4a6f34f01bbd47f4be49be110b2f6e3c7b8bdb3a
-EBUILD plyvel-1.0.5.ebuild 1250 BLAKE2B 2f231e794eb55080b1de3a3b9cefd855cf3e146cf27d0e96e8818c9a3cac5d2fded95202b0b74b3e6cc2daac61f7ed144d99da3e3f3ed25b04e5ab0af27f1d2d SHA512 a5fa5e18380359f13d9f2a71e7f4f3002246d9bf26bbc24a6fd2ad7bfac8ad58dcf9465d0e46b8c630d8d084b304331de1516fec648270aa9eb03639af54b8ff
-EBUILD plyvel-1.1.0.ebuild 1253 BLAKE2B 4051f1cd5af9b5ee3a15e6797682feae95e75232db1d5569f919d42da9bb09863290ed43682ec8e623e10f3fe9f927b3d431bb3adb0e4a4dd40802f07e9e4b69 SHA512 51b105873ba7260857d8d407119911e0be62f44ca9b1d8c8748292cb7985a0b6c6db56ada7459d33e78719c1b9c3e9cc012fbbe932868d38d29222e6338ecde9
+EBUILD plyvel-1.0.5.ebuild 1053 BLAKE2B 502e224111d99a312232cfbbc3ca755dc6383b99b9f2e954292ab7b571190e3f717a9ad2034b422aa912a0e41998453eca7e91a9765e62df2b1a1a63e879d140 SHA512 fef6e7ba1143c6598c603f1a780be7cd5a05d2a2b920c0a68f9cfac51dc8c86d446237c1765fb38c08a10021f336a74e6b570b2492b55707ed8e727ae7928a07
+EBUILD plyvel-1.1.0.ebuild 1056 BLAKE2B 0a5ede3289410bfc2f18c1e92eb5056c3a732ab22074e5f9c2c7edae820c32c3de219e3aec43629eb9bd09e6e9a74db9f15b1476cdedd32397cfc390cf47fce0 SHA512 f16d964c8b4d889d5d7000ab16f605202e194a3481135698b1de32ca32aa95c2a905daaee6327005864a95fad3ff440b15f6db9ca092c91a62b0f13965281051
MISC metadata.xml 432 BLAKE2B 5ff794b8cd6bb312ed6fc0a3ef74ab6a89be65b45d90fee726ec4350f702b45e46da69c35ac2fea606bdd2b7cc87a9d360ce03d101b4243950cbd54567a772d7 SHA512 fbd7143b819341c3d6686e6861b5c8642b6e18f3e0c73b0ab0221dae9f074fba26d7792f41a23a67074679594ed2739a9a6926124365c1fab88765e51915f288
diff --git a/dev-python/plyvel/plyvel-1.0.5.ebuild b/dev-python/plyvel/plyvel-1.0.5.ebuild
index 953e10d1c72d..8006345f9308 100644
--- a/dev-python/plyvel/plyvel-1.0.5.ebuild
+++ b/dev-python/plyvel/plyvel-1.0.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{6,7} )
inherit distutils-r1
@@ -28,12 +28,6 @@ DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-python_compile() {
- # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_compile_all() {
if use doc; then
sphinx-build doc doc/_build/html || die
diff --git a/dev-python/plyvel/plyvel-1.1.0.ebuild b/dev-python/plyvel/plyvel-1.1.0.ebuild
index e03758e6af93..7b5f43428317 100644
--- a/dev-python/plyvel/plyvel-1.1.0.ebuild
+++ b/dev-python/plyvel/plyvel-1.1.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{6,7} )
inherit distutils-r1
@@ -28,12 +28,6 @@ DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-python_compile() {
- # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_compile_all() {
if use doc; then
sphinx-build doc doc/_build/html || die