summaryrefslogtreecommitdiff
path: root/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/plumbum/plumbum-1.7.0-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/plumbum/plumbum-1.7.0-r1.ebuild')
-rw-r--r--dev-python/plumbum/plumbum-1.7.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..da3985d2cb5b
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
+SRC_URI="https://files.pythonhosted.org/packages/ed/ba/431d7f420cd93c4b8ccb15ed8f1c6c76c81965634fd70345af0b19c2b7bc/${P}.tar.gz"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}] )"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-1.7.0-test.patch )
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Need sshd running
+ rm tests/test_remote.py || die "rm test_remote.py failed"
+ rm tests/test_utils.py || die "rm test_utils.py failed"
+ rm tests/_test_paramiko.py || die "rm _test_paramiko.py failed"
+ # Windows specific
+ rm tests/test_putty.py || die "rm test_putty.py failed"
+ # Needs sudo without password
+ rm tests/test_sudo.py || die "rm test_sudo.py failed"
+}
+
+pkg_postinst() {
+ elog "To get additional features, optional runtime dependencies may be installed:"
+ optfeature "Remote commands via ssh" dev-python/paramiko
+ optfeature "Progress bars in jupyter" dev-python/ipywidgets
+ optfeature "Colored output in jupyter" dev-python/ipython
+ optfeature "Images on the command line" dev-python/pillow
+ elog ""
+}