summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/plumbum
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest3
-rw-r--r--dev-python/plumbum/files/plumbum-1.7.0-test.patch34
-rw-r--r--dev-python/plumbum/plumbum-1.7.0-r1.ebuild41
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index addceb65a891..5c04d6d73f43 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,3 +1,6 @@
+AUX plumbum-1.7.0-test.patch 1434 BLAKE2B 1b857261671912f2f708dae0b3aad50cd0d406697b451e31c314d8da931a279c8cfe2ccc80459b93b8f4c32ec7bb6c858c81014e6081719812eb76f8f64f79a3 SHA512 bec0051177757f09dcd53f9b6ed95ef83892c28a6e72e18acfda2e01c64660975d3fd3e82542a574f036cb48582325a8ad628ac6dc9d19d8e2780ba50c617015
DIST plumbum-1.6.9.tar.gz 311240 BLAKE2B e5f833a5c762f3e78e5f47649306c7c29e6276b3530ff45fc0c12cc4efd3bf89bad2b6b7f77e4b3e3a0a47671f9b607e667aba8f654c28c05be570e0a7491a07 SHA512 f165f4905ec34cfe072f61fb28b43021ca44c0c3cb1e505faa04332d15920d832bcf084782683c4950113e30a3fa29734846b3b6f31604e1a635c9c125e38ef1
+DIST plumbum-1.7.0.tar.gz 318890 BLAKE2B 19ae8a37dff38ac3d263d9400e44ac174c46ff8cef92cf45b9ea31d6d344543fba66de3fd0fcd15acc205af5939f11be6c56e6cd9ca39a666f92f18dcd29b9f7 SHA512 0a12891278c12bb98b8bbb825448375240ee347eb3ca166b9cbb4da3e083979d947a7bf0a843fd9a0b7c9a13d09f24e988ee877f29420a3f29f40e387eec8826
EBUILD plumbum-1.6.9.ebuild 520 BLAKE2B 5c2cb8e217932f49f659c27725e637ec233e75c5cb4835e540ead7521096c9fd48c66ec9ee5e04bc1f5a6620199b041f2cae28efce809d00c5201076eb4231bb SHA512 8b630331b6998b172c5580e7b12ed12cf9dde1fdc1237257f9a61342a64f5a02ce4d1f6f63dbd54caedacb8ae24170e2244717dae7c4e86055653bcf585e7b07
+EBUILD plumbum-1.7.0-r1.ebuild 1497 BLAKE2B dbef6d32f12156cbb99e94ead5e9dd9709cf64b2b3ee4a4d8618c4f0a69a041818327e0531f54054916426ef0b04d12be14d3e42fac94330ebf5251ed7e5c0f9 SHA512 5a8bb4e7fc32fd2ef77255f1a50360a00ad0eff5da5f06bff29539daa1e320fcd852c85ca71e21ce73ef6fba51bd9c6aafd9f3104a938a32fda3716629cc2756
MISC metadata.xml 753 BLAKE2B c3723646f700efe4448d60c83c7b636db5b618076e6baba2201ab84f7f55953626df54c6d9b7ee368420ee4e94605b5e0129bb4e40bd412c7737a987c8aa0cd2 SHA512 5d1ce42aef769e6681ba77cf4f8f493697f9ec20cd648ce68ace94be9d6b022144e558f222a9950966b8d0e3e2c0297438e174ea02e3ce329c038e58c9573490
diff --git a/dev-python/plumbum/files/plumbum-1.7.0-test.patch b/dev-python/plumbum/files/plumbum-1.7.0-test.patch
new file mode 100644
index 000000000000..a79c5f67d18a
--- /dev/null
+++ b/dev-python/plumbum/files/plumbum-1.7.0-test.patch
@@ -0,0 +1,34 @@
+diff -r -U2 plumbum-1.7.0.orig/setup.cfg plumbum-1.7.0/setup.cfg
+--- plumbum-1.7.0.orig/setup.cfg 2021-02-09 02:46:57.071159800 +0700
++++ plumbum-1.7.0/setup.cfg 2021-03-15 15:51:13.873287602 +0700
+@@ -66,5 +66,4 @@
+
+ [tool:pytest]
+-addopts = -v -ra --cov-config=setup.cfg
+ norecursedirs = examples experiments
+ timeout = 300
+diff -r -U2 plumbum-1.7.0.orig/tests/test_env.py plumbum-1.7.0/tests/test_env.py
+--- plumbum-1.7.0.orig/tests/test_env.py 2021-02-09 02:46:46.000000000 +0700
++++ plumbum-1.7.0/tests/test_env.py 2021-03-15 15:50:18.943289430 +0700
+@@ -14,4 +14,5 @@
+ @skip_on_windows
+ class TestEnv:
++ @pytest.mark.skip("Something wrong here")
+ def test_change_env(self):
+ with local.env(silly=12):
+@@ -23,4 +24,5 @@
+ assert len(local.env) == len(actual)
+
++ @pytest.mark.skip("Something wrong here")
+ def test_dictlike(self):
+ keys = {x.split("=")[0] for x in printenv().splitlines() if "=" in x}
+diff -r -U2 plumbum-1.7.0.orig/tests/test_local.py plumbum-1.7.0/tests/test_local.py
+--- plumbum-1.7.0.orig/tests/test_local.py 2021-02-09 02:46:46.000000000 +0700
++++ plumbum-1.7.0/tests/test_local.py 2021-03-15 15:50:18.943289430 +0700
+@@ -168,5 +168,5 @@
+ assert parts == ("/", "some", "long", "path", "to", "file.txt")
+
+- @pytest.mark.usefixtures("testdir")
++ @pytest.mark.skip("Something wrong here")
+ def test_iterdir(self):
+ cwd = local.path(".")
diff --git a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..da3985d2cb5b
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
+SRC_URI="https://files.pythonhosted.org/packages/ed/ba/431d7f420cd93c4b8ccb15ed8f1c6c76c81965634fd70345af0b19c2b7bc/${P}.tar.gz"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}] )"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-1.7.0-test.patch )
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Need sshd running
+ rm tests/test_remote.py || die "rm test_remote.py failed"
+ rm tests/test_utils.py || die "rm test_utils.py failed"
+ rm tests/_test_paramiko.py || die "rm _test_paramiko.py failed"
+ # Windows specific
+ rm tests/test_putty.py || die "rm test_putty.py failed"
+ # Needs sudo without password
+ rm tests/test_sudo.py || die "rm test_sudo.py failed"
+}
+
+pkg_postinst() {
+ elog "To get additional features, optional runtime dependencies may be installed:"
+ optfeature "Remote commands via ssh" dev-python/paramiko
+ optfeature "Progress bars in jupyter" dev-python/ipywidgets
+ optfeature "Colored output in jupyter" dev-python/ipython
+ optfeature "Images on the command line" dev-python/pillow
+ elog ""
+}