summaryrefslogtreecommitdiff
path: root/dev-python/plotly/plotly-1.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/plotly/plotly-1.9.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/plotly/plotly-1.9.6.ebuild')
-rw-r--r--dev-python/plotly/plotly-1.9.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/plotly/plotly-1.9.6.ebuild b/dev-python/plotly/plotly-1.9.6.ebuild
new file mode 100644
index 000000000000..ac75ea7f3b33
--- /dev/null
+++ b/dev-python/plotly/plotly-1.9.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"