summaryrefslogtreecommitdiff
path: root/dev-python/plotly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/plotly
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/plotly')
-rw-r--r--dev-python/plotly/Manifest4
-rw-r--r--dev-python/plotly/metadata.xml16
-rw-r--r--dev-python/plotly/plotly-1.9.6.ebuild25
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/plotly/Manifest b/dev-python/plotly/Manifest
new file mode 100644
index 000000000000..30bc353892bc
--- /dev/null
+++ b/dev-python/plotly/Manifest
@@ -0,0 +1,4 @@
+DIST plotly-1.9.6.tar.gz 546722 SHA256 dda34435910787c40e7622aea2992d1b48301d12eef36a7a0bf6d0f93e420305 SHA512 7564036ed3745fc06ee7428942e45ca6bfaefa1e47b08a5868a918924268ee632515f1de4bf3e90911234f18a4d85b092ecb6ef9f213b939093dcb433a12dec4 WHIRLPOOL 7eb0f75d08c255a3d8fe3d4d673b8346963f6d22c8eba1e57dacffa799fac34b4c7acd3f52b5667e7e2d42054d9efaeb4466290d91f54b8b45e1f7cc63ade902
+EBUILD plotly-1.9.6.ebuild 590 SHA256 18bfa4e4bdca073a338685bfb9382a0fee9fa231f0e4274dca11c5cd9fe6f137 SHA512 3b86bb14ab95c6ae50d877a3a0a11e425173fc2ceff15d6293399881b5a67b1621e24040f5e05735d26a1187c5b58a80e0aef88f137021650a13a8e62bc8dc02 WHIRLPOOL 60b2a982fb0a73794f3555ae70947bd6cbbf205d7da9ddd02063e20e21cbfa36365edd4153abf289b9f8f4ff5e732747ba6ef286f0d534f777abd170a3172981
+MISC ChangeLog 313 SHA256 9dff8fff2368694e593c6df3be6bed411f58028e50d73440956381fe8b1036dd SHA512 9bc12974fa3db13adebf1c5b531785c646bc4764de94cdd7b919d6fb660d29b4d132689004688a782e5c107b2ee011cdd815fadc6e98cb159db58c5b89e1cb62 WHIRLPOOL 258442a25d91db1b497ed5c7cc8807de86764670eadaa088d86aca9877fc60b61ff3af371eee2be3a7a1274f51419db43e64cf5352b5a2b2d902ff503594021b
+MISC metadata.xml 601 SHA256 5cbce202f5d8b753112c62a4305d56c48af66e194146eced03958bf89034defc SHA512 6a9af070fbe6fd992fa2131491b742c7d92c8fdc30993d1c92185c5bb4dbd42c9a9f84bbf6a9b710d5c731d820e3610d00258fcc284ea7388e1acf56fd3840b9 WHIRLPOOL d56e2bbaaa1700796fcfe664f5c06287f38feed5cc9818c82901194dcd0abb22f23b2c652eb3073783f7ef816c50c16c034a7d61476070f6246befd45f9edbde
diff --git a/dev-python/plotly/metadata.xml b/dev-python/plotly/metadata.xml
new file mode 100644
index 000000000000..b92ec11d7525
--- /dev/null
+++ b/dev-python/plotly/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python plotting library for collaborative, interactive, publication-quality
+ graphs. Plotly is an online collaborative data analysis and graphing tool.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">plotly</remote-id>
+ <remote-id type="github">plotly/plotly.py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/plotly/plotly-1.9.6.ebuild b/dev-python/plotly/plotly-1.9.6.ebuild
new file mode 100644
index 000000000000..ac75ea7f3b33
--- /dev/null
+++ b/dev-python/plotly/plotly-1.9.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"