summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pbr
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest4
-rw-r--r--dev-python/pbr/pbr-5.4.5-r1.ebuild (renamed from dev-python/pbr/pbr-5.4.5.ebuild)32
-rw-r--r--dev-python/pbr/pbr-5.5.0-r1.ebuild (renamed from dev-python/pbr/pbr-5.5.0.ebuild)32
3 files changed, 26 insertions, 42 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 92dc233e8f0c..62d2eb02c8e0 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,5 +1,5 @@
DIST pbr-5.4.5.tar.gz 120510 BLAKE2B f0f22a25e41820a0848aface6c241e38d8c4500d14ac3c8abf3d3b5f3f2d88680505d43f045589d700e9c07ade1643712274b156832246ca3f2050f44e4cda26 SHA512 b53ca10b7af7e365ff99ecf11942d3f047112d69f7e963716d07bc156077b08d79bb708bb93aae342e5e03c83278507b6990137dc34d0ebc11de53bd57ab3654
DIST pbr-5.5.0.tar.gz 117967 BLAKE2B cc3f023493150f0687ede07ccadc3abfb4a8dc5e0cdc0f9fd946d3a28fe2cf496683f37f934a5555875b5ac0546a0c0ed99e1bc2f7be53b47ec68d64d27cb78a SHA512 ce187787d5a51700d854790b329274aafd7d4f9e724b1b69b5ea8684cdc58c738274d30fd85bb890671bb77f2c7c88ccb488ea11df7ae9fd0505b4dc29292889
-EBUILD pbr-5.4.5.ebuild 2497 BLAKE2B 1fdfe4a2af6eb1757f279127b6e02dc0bab35c32cbaf74b97145a4a15d15a057eda21ff65e4aff21d05e28d53cdf21e2a345a2c64273c28fbf7ac09601d1b6c0 SHA512 6c94faf041ac2cf9931753a3f2399ac27d52c939d2b151bdae36fb7a2724d2feb807d7e691a8634235fd700071873076a242498c9b22c0d97217e030f371e9df
-EBUILD pbr-5.5.0.ebuild 2321 BLAKE2B 03a2af0cbdca8b229d12fcb00f5b0fc3032e8fe34a718cd1d8122fdf307433d527c6dc64249b30faccc735a39ae70539255c15d1498ee260eb95ca2ab18704e9 SHA512 29dc669ce26a1b739ba1a44466b067fd981bb595d3d9556f793613f64760404c67f94c1a478e5a745ad1675f6f0acc72abc82c181ea21e385270e1e01a72aed2
+EBUILD pbr-5.4.5-r1.ebuild 2296 BLAKE2B 0b406a9dc60649b7506a02b34854927529d6815d0e9ecbd06668a25af601bfce81b451407f7403102fd9f001aeb17dd4083d22585f3dbe7ff59417a22c0c088b SHA512 07fb007759938be0866bb33a75c346a889f6df35651210e5ab5785efb53d5627d2f4544de57d81ef075b99593901b6b9c377dd93f7ad11d9b860ccdbc22fbb28
+EBUILD pbr-5.5.0-r1.ebuild 2120 BLAKE2B 13de15d7a4fc9779ab19418c4fb7cbfe316c5e92ec856a5dae2e0e618276b4c0717cb040940ad09895c60de482920e98f9173ea4a2438956de08ce50fc09b0f2 SHA512 f14317f1668fecca804999b43825d41eeff01d4d78747b0d5829937b51d171f1df5ae125ec5585fdcb6533011e33329f311d240d7608c426c36b2a57adaf44c9
MISC metadata.xml 818 BLAKE2B b3ed054273dccfd8cd24f2e86e1505be70445aa45d193d37c30e6f5abcfcab489d59cb6a1e11d54cea70bbbcd152d9a208dc32237058537b99061172f573b868 SHA512 3d21678a6769bea88b901391d5df75882798e49ab5266ab7d5a73282c30793e479ebbe24cbb5b7d35ad19b517996e52243d238632a390f136ff30f77f54436fe
diff --git a/dev-python/pbr/pbr-5.4.5.ebuild b/dev-python/pbr/pbr-5.4.5-r1.ebuild
index 36454f258a7f..b9f96cb30731 100644
--- a/dev-python/pbr/pbr-5.4.5.ebuild
+++ b/dev-python/pbr/pbr-5.4.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -25,19 +25,17 @@ RESTRICT="!test? ( test )"
# stestr is run as external tool
BDEPEND="
test? (
- $(python_gen_cond_dep '
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- <dev-python/virtualenv-20[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.1.0
- dev-vcs/git
- ' -3)
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ <dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0
+ dev-vcs/git
)"
PDEPEND=""
@@ -57,12 +55,6 @@ python_prepare_all() {
}
python_test() {
- if ! python_is_python3; then
- ewarn "Skipping tests on ${EPYTHON} to unblock circular deps."
- ewarn "Please run tests manually."
- return
- fi
-
distutils_install_for_testing
local -x PATH=${TEST_DIR}/scripts:${PATH}
diff --git a/dev-python/pbr/pbr-5.5.0.ebuild b/dev-python/pbr/pbr-5.5.0-r1.ebuild
index a738c43b0daf..7e7e611dcad7 100644
--- a/dev-python/pbr/pbr-5.5.0.ebuild
+++ b/dev-python/pbr/pbr-5.5.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -24,19 +24,17 @@ RESTRICT="!test? ( test )"
# stestr is run as external tool
BDEPEND="
test? (
- $(python_gen_cond_dep '
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.1.0
- dev-vcs/git
- ' -3)
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0
+ dev-vcs/git
)"
PDEPEND=""
@@ -56,12 +54,6 @@ python_prepare_all() {
}
python_test() {
- if ! python_is_python3; then
- ewarn "Skipping tests on ${EPYTHON} to unblock circular deps."
- ewarn "Please run tests manually."
- return
- fi
-
distutils_install_for_testing
local -x PATH=${TEST_DIR}/scripts:${PATH}