summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pbr
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/pbr-5.5.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 818601205a08..92dc233e8f0c 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,3 +1,5 @@
DIST pbr-5.4.5.tar.gz 120510 BLAKE2B f0f22a25e41820a0848aface6c241e38d8c4500d14ac3c8abf3d3b5f3f2d88680505d43f045589d700e9c07ade1643712274b156832246ca3f2050f44e4cda26 SHA512 b53ca10b7af7e365ff99ecf11942d3f047112d69f7e963716d07bc156077b08d79bb708bb93aae342e5e03c83278507b6990137dc34d0ebc11de53bd57ab3654
+DIST pbr-5.5.0.tar.gz 117967 BLAKE2B cc3f023493150f0687ede07ccadc3abfb4a8dc5e0cdc0f9fd946d3a28fe2cf496683f37f934a5555875b5ac0546a0c0ed99e1bc2f7be53b47ec68d64d27cb78a SHA512 ce187787d5a51700d854790b329274aafd7d4f9e724b1b69b5ea8684cdc58c738274d30fd85bb890671bb77f2c7c88ccb488ea11df7ae9fd0505b4dc29292889
EBUILD pbr-5.4.5.ebuild 2497 BLAKE2B 1fdfe4a2af6eb1757f279127b6e02dc0bab35c32cbaf74b97145a4a15d15a057eda21ff65e4aff21d05e28d53cdf21e2a345a2c64273c28fbf7ac09601d1b6c0 SHA512 6c94faf041ac2cf9931753a3f2399ac27d52c939d2b151bdae36fb7a2724d2feb807d7e691a8634235fd700071873076a242498c9b22c0d97217e030f371e9df
+EBUILD pbr-5.5.0.ebuild 2321 BLAKE2B 03a2af0cbdca8b229d12fcb00f5b0fc3032e8fe34a718cd1d8122fdf307433d527c6dc64249b30faccc735a39ae70539255c15d1498ee260eb95ca2ab18704e9 SHA512 29dc669ce26a1b739ba1a44466b067fd981bb595d3d9556f793613f64760404c67f94c1a478e5a745ad1675f6f0acc72abc82c181ea21e385270e1e01a72aed2
MISC metadata.xml 818 BLAKE2B b3ed054273dccfd8cd24f2e86e1505be70445aa45d193d37c30e6f5abcfcab489d59cb6a1e11d54cea70bbbcd152d9a208dc32237058537b99061172f573b868 SHA512 3d21678a6769bea88b901391d5df75882798e49ab5266ab7d5a73282c30793e479ebbe24cbb5b7d35ad19b517996e52243d238632a390f136ff30f77f54436fe
diff --git a/dev-python/pbr/pbr-5.5.0.ebuild b/dev-python/pbr/pbr-5.5.0.ebuild
new file mode 100644
index 000000000000..a738c43b0daf
--- /dev/null
+++ b/dev-python/pbr/pbr-5.5.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0
+ dev-vcs/git
+ ' -3)
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # TODO: investigate
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ # broken on pypy3
+ # https://bugs.launchpad.net/pbr/+bug/1881479
+ sed -e 's:test_generates_c_extensions:_&:' \
+ -i pbr/tests/test_packaging.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if ! python_is_python3; then
+ ewarn "Skipping tests on ${EPYTHON} to unblock circular deps."
+ ewarn "Please run tests manually."
+ return
+ fi
+
+ distutils_install_for_testing
+ local -x PATH=${TEST_DIR}/scripts:${PATH}
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ stestr init || die "stestr init failed under ${EPYTHON}"
+ stestr run || die "stestr run failed under ${EPYTHON}"
+}