summaryrefslogtreecommitdiff
path: root/dev-python/pathlib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 16:19:20 +0100
commit312456186919deebd1ea3b34b9e26b1e15ebd5b6 (patch)
tree9f41dbee43e2392f0e58ed3b9f43ce41e8d18fce /dev-python/pathlib2
parentfe2f8d9da0555e4ed15cc203d8dd99dd60b3117e (diff)
gentoo auto-resync : 03:09:2022 - 16:19:20
Diffstat (limited to 'dev-python/pathlib2')
-rw-r--r--dev-python/pathlib2/Manifest3
-rw-r--r--dev-python/pathlib2/metadata.xml13
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
new file mode 100644
index 000000000000..9a85f17b10db
--- /dev/null
+++ b/dev-python/pathlib2/Manifest
@@ -0,0 +1,3 @@
+DIST pathlib2-2.3.7-post1.gh.tar.gz 39281 BLAKE2B 71448eeb24cc149eb540b5b2f5f39cb1c7273ecbe9491eb049e8e1a721db4bde478bcd6cfadc7bc954c924eb26f1c5950fd4a8c5503a87dc3faec7866a23d0a8 SHA512 8eef6dcbd4b264365499ad0b53321fb1dce3b56377e91288a9d2b769775f9d697736e1136fe43d17147b8539fdad666e9b1f5fc22ecc63a601ce87434ba6aab1
+EBUILD pathlib2-2.3.7_p1.ebuild 654 BLAKE2B 3f40f71ec86b9fa9db38bb2703c2b2ca893f0709020ddb750ddd7ab5c3eca1a482d7bf319de0176ef5ce2d0a7b40a3282b135ff116b96578afc1802c1a7bd650 SHA512 db9e3dce6bb8d75f72632fc6642b1831ac3adf38f3ab894b821cbe27eaf8bfc2d7dbb0abae091126d9bda76f7d57893be99188ed0d9c10feb68a4d0f4adc66a0
+MISC metadata.xml 393 BLAKE2B df9eb719122443ad17e77076dc47c256a9d583137657cdfb6b20d09c19546425443b63b6ab3bfd94dadaa4273f444ffdb265c053c81793b2b56bac75a4e15e23 SHA512 08504588b43aa37e764a2c48817a8ac7a65ca19965bc8b00d616300560e794423dd931c29160d50ffaf30d19bf6f41a125287e9a3c013ffaa97e300a1e0b6725
diff --git a/dev-python/pathlib2/metadata.xml b/dev-python/pathlib2/metadata.xml
new file mode 100644
index 000000000000..f1aba8b00fba
--- /dev/null
+++ b/dev-python/pathlib2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pathlib2</remote-id>
+ <remote-id type="github">jazzband/pathlib2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild b/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild
new file mode 100644
index 000000000000..778031c0f2c8
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# this is a backport, please do not add newer impls unless necessary
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/-post}
+DESCRIPTION="Backport of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="
+ https://pypi.org/project/pathlib2/
+ https://github.com/jazzband/pathlib2/
+"
+SRC_URI="
+ https://github.com/jazzband/pathlib2/archive/${PV/_p/-post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest