summaryrefslogtreecommitdiff
path: root/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild b/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild
new file mode 100644
index 000000000000..778031c0f2c8
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.7_p1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# this is a backport, please do not add newer impls unless necessary
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/-post}
+DESCRIPTION="Backport of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="
+ https://pypi.org/project/pathlib2/
+ https://github.com/jazzband/pathlib2/
+"
+SRC_URI="
+ https://github.com/jazzband/pathlib2/archive/${PV/_p/-post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest