summaryrefslogtreecommitdiff
path: root/dev-python/passlib/passlib-1.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/passlib/passlib-1.7.2.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/passlib/passlib-1.7.2.ebuild')
-rw-r--r--dev-python/passlib/passlib-1.7.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/passlib/passlib-1.7.2.ebuild b/dev-python/passlib/passlib-1.7.2.ebuild
index aaa2485c0159..da3cd45d5bee 100644
--- a/dev-python/passlib/passlib-1.7.2.ebuild
+++ b/dev-python/passlib/passlib-1.7.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
inherit distutils-r1
@@ -18,11 +18,16 @@ IUSE="+bcrypt doc +scrypt +totp"
RDEPEND="bcrypt? ( dev-python/bcrypt[${PYTHON_USEDEP}] )
totp? ( dev-python/cryptography[${PYTHON_USEDEP}] )
scrypt? ( dev-python/scrypt[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/scrypt[${PYTHON_USEDEP}]
+ )"
PATCHES=(
"${FILESDIR}/passlib-1.7.2-pypy3.patch"
+ "${FILESDIR}/passlib-1.7.2-py39.patch"
)
distutils_enable_tests nose