summaryrefslogtreecommitdiff
path: root/dev-python/passlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/passlib
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/Manifest3
-rw-r--r--dev-python/passlib/files/passlib-1.7.2-py39.patch19
-rw-r--r--dev-python/passlib/passlib-1.7.2.ebuild11
3 files changed, 29 insertions, 4 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index 31cf054415c7..2bd923a9f38d 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1,5 +1,6 @@
AUX passlib-1.7.1-tests.patch 1552 BLAKE2B 86cfedd409d6aff983c31ec33362577e5e353fa00fafed47927cec318d79d79fea75af80a283ef23b6453fb2da1bb5c46ae513b784e97941a8a45dfd4089bb26 SHA512 ccdf6814890e1c25b5eed9b2685ca2778fe155c3f7d75f2b76433a91785baa93b692aa6ee0f3a85b768f3b0189be185acce1e570961d28540d8f9dd12a81db7d
+AUX passlib-1.7.2-py39.patch 870 BLAKE2B 87781afb87427dd78c9040babdb2c3be9f8b14099bee1d1e0cbd0a1bc0deee56b0ba0f65adaa5a9bbd81fd998152661db5a602127a74e59bc1aa07d1ce1e1c46 SHA512 a77f51cad2c460abc41b99cf59c76f33c1a15a51b4237c968185dc46c11c6e4aa1dd866082df13cd9b34f7496c9750c276c18dab8ea08056200d125e3dccb324
AUX passlib-1.7.2-pypy3.patch 3117 BLAKE2B c68b96cddf48038198e7d5d35da33c581c2abcf1aef75e6ca556c39a87e242e9990ed17235596ffb68a4154eec9acb6fcb0d651a04856a93f79a993865d702f7 SHA512 808fc0f3067f30f23118b5222d90f86910b3e681c585d1bdb237a2b954ff99936105042f2a0fce8f4ae2b0301cd201be68905be316fed5ebfd81ccc1cf29fd1a
DIST passlib-1.7.2.tar.gz 649654 BLAKE2B 40279113d9ff633cea47222f2d72af0abee78dc52a9b46adf66aaae213594eaae7f245cc80004f85b5055b882741b4bedfd81ee39132db23760d37a34e87ac6a SHA512 1ea0654b177b5ab2e1a7e5c3949642c34805ace6e4e4a0f82fafdb3f374edd99c667906ce598c335b668da049860648d5cbebb3e62d775898d5b0cb8cfc7bf53
-EBUILD passlib-1.7.2.ebuild 895 BLAKE2B 90bfc63a93d04a85193da5fa2f57951ed40e7d44657fbfdfb886e6d48f9af6a6858e6cbdcd5fb579fe40e576ac6cddce67d4a95cee3202b866bd87d0b46f372d SHA512 ba802b0c632a3b77e9c0db519fffd4acb6d46cf44d71589717cbcea0dcb382cc87e00c7d9e81eb53609de8d0934b6f232931a4a8360f03311dfbc0a00660b18a
+EBUILD passlib-1.7.2.ebuild 1019 BLAKE2B 02b96bfd68d6e1a1969e66688ceaca528f46e9489651ce5704c4b9653d7e2821abdc759791ee496bcbf6f40c220b87c8464f35940fcd1410b13f63cd8c7ed903 SHA512 ab0bfef4de8726aacab5a5901818ff7ae1ec0f4afd89e4939ffd84349d310aa1e4fa597e44c89f9470b7fbde073e10785d78dd533c8851cffb24876a21ce8b21
MISC metadata.xml 794 BLAKE2B 717057e0abe888ef6c692a0777d9c106426238d690934a852fea3084154dfa190546c1779c6da9fbda61f6b204bfb152cf391727c4225baf2f0d6030d4ad6be5 SHA512 baf29cb74e295119b984f3acc3470f63811f9ee49849e97b1808354c15be121e723fabafb053a0a7c94032faa7747d149d000b68acfccd919ea4ec9d28d2f930
diff --git a/dev-python/passlib/files/passlib-1.7.2-py39.patch b/dev-python/passlib/files/passlib-1.7.2-py39.patch
new file mode 100644
index 000000000000..c5dbc208a88b
--- /dev/null
+++ b/dev-python/passlib/files/passlib-1.7.2-py39.patch
@@ -0,0 +1,19 @@
+diff --git a/passlib/utils/__init__.py b/passlib/utils/__init__.py
+index 69b55e5..d18ec50 100644
+--- a/passlib/utils/__init__.py
++++ b/passlib/utils/__init__.py
+@@ -807,7 +807,13 @@ else:
+
+ if isinstance(hash, bytes):
+ hash = hash.decode("ascii")
+- result = _crypt(secret, hash)
++ try:
++ result = _crypt(secret, hash)
++ except OSError:
++ # new in py39 -- per https://bugs.python.org/issue39289,
++ # crypt() now throws OSError for various things, mainly unknown hash formats
++ # translating that to None for now (may revise safe_crypt behavior in future)
++ return None
+ if PYPY and isinstance(result, bytes):
+ result = result.decode("utf-8")
+ if not result or result[0:1] in _invalid_prefixes:
diff --git a/dev-python/passlib/passlib-1.7.2.ebuild b/dev-python/passlib/passlib-1.7.2.ebuild
index aaa2485c0159..da3cd45d5bee 100644
--- a/dev-python/passlib/passlib-1.7.2.ebuild
+++ b/dev-python/passlib/passlib-1.7.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
inherit distutils-r1
@@ -18,11 +18,16 @@ IUSE="+bcrypt doc +scrypt +totp"
RDEPEND="bcrypt? ( dev-python/bcrypt[${PYTHON_USEDEP}] )
totp? ( dev-python/cryptography[${PYTHON_USEDEP}] )
scrypt? ( dev-python/scrypt[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/scrypt[${PYTHON_USEDEP}]
+ )"
PATCHES=(
"${FILESDIR}/passlib-1.7.2-pypy3.patch"
+ "${FILESDIR}/passlib-1.7.2-py39.patch"
)
distutils_enable_tests nose