summaryrefslogtreecommitdiff
path: root/dev-python/notify2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/notify2
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/Manifest4
-rw-r--r--dev-python/notify2/metadata.xml15
-rw-r--r--dev-python/notify2/notify2-0.3.ebuild30
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/notify2/Manifest b/dev-python/notify2/Manifest
new file mode 100644
index 000000000000..1e8bb9e7768b
--- /dev/null
+++ b/dev-python/notify2/Manifest
@@ -0,0 +1,4 @@
+DIST notify2-0.3.tar.gz 8798 SHA256 684281f91c51fc60bc7909a35bd21d043a2a421f4e269de1ed1f13845d1d6321 SHA512 3290a5ff291d5500bcf631094fcf10302b234353eb8c26b91e7cd264238443866aadc15224d51eb6608e16b7ffbc9316d4bc551e5ad9de2a48b12a31b195739f WHIRLPOOL f28d569baafecaad0b2bf42856c67371ac42660dd6259a91b1d06bbcd0da15c0cfe0a87d72c2171cc23f01cacb104b633c4c386178760441ebcc8c58b32407f9
+EBUILD notify2-0.3.ebuild 653 SHA256 22199495689d3f00972a72e43da1c90f88685819a95cb79c1e970b8c3d884333 SHA512 f278fcf00bd29146f4c09e717a7ec102f363c3b1db1ae87a2a6c07e1efc75adde1c3611578de0c4b41598714ee327723aa13c1773c7f502704b2a08a996ef49f WHIRLPOOL 60e1ab3ae46748f7a9f353a5eccc2a6d5930f200eb11a0ba0020b14f664ae03c107954b903220dcb69f8536c011439008567a837ff889658500ef16cafc25e49
+MISC ChangeLog 325 SHA256 8d319081bea846e324c137e5c7cc895d3a5c36091468b4414dea738ad8c9ad97 SHA512 70c102be810e6a00067677f6ba1c85e77450c88c8fcd8078065ca07346bd549d66afec210e2d59b65791a12093690e688ffa0551a418b484052481dd6aa7842e WHIRLPOOL 07bce655de2e6277e7db3be356aaa365f95676633dc542385b4591f971a9f09274088842ca6b014b40f53282abca7577e2b3d32f1e6011f56a284cf24b38863c
+MISC metadata.xml 465 SHA256 81976400ef24f95b67659ea3a08903e8c65119e07df64b721d6bd62ea46e5766 SHA512 8024b5c580d09b74bf6a258dad507bec09d0c7bbbd10861bc2f866dd71acd7a858e7175dcb1d670cfdbade64da3f607667434a8587de6ceaeee7da028ce332ba WHIRLPOOL ba78331445dd5f213006e2a441f9caa9fb915130a805f23a67e210e901ac6c2054d6c3d4fdb3a6d1a7017085a85e7029d870a577323f794af067f93d62f69643
diff --git a/dev-python/notify2/metadata.xml b/dev-python/notify2/metadata.xml
new file mode 100644
index 000000000000..f05b38bba4f5
--- /dev/null
+++ b/dev-python/notify2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">takluyver/pynotify2</remote-id>
+ <remote-id type="pypi">notify2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/notify2/notify2-0.3.ebuild b/dev-python/notify2/notify2-0.3.ebuild
new file mode 100644
index 000000000000..a36960451652
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test_notify2.py || die
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}