summaryrefslogtreecommitdiff
path: root/dev-python/notify2/notify2-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/notify2/notify2-0.3.ebuild')
-rw-r--r--dev-python/notify2/notify2-0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/notify2/notify2-0.3.ebuild b/dev-python/notify2/notify2-0.3.ebuild
new file mode 100644
index 000000000000..a36960451652
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test_notify2.py || die
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}