summaryrefslogtreecommitdiff
path: root/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nbsphinx/nbsphinx-0.2.14.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nbsphinx/nbsphinx-0.2.14.ebuild')
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.2.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild b/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild
new file mode 100644
index 000000000000..2d245d087a3f
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"