summaryrefslogtreecommitdiff
path: root/dev-python/nbsphinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nbsphinx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nbsphinx')
-rw-r--r--dev-python/nbsphinx/Manifest3
-rw-r--r--dev-python/nbsphinx/metadata.xml20
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.2.14.ebuild27
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
new file mode 100644
index 000000000000..1642015154bd
--- /dev/null
+++ b/dev-python/nbsphinx/Manifest
@@ -0,0 +1,3 @@
+DIST nbsphinx-0.2.14.tar.gz 98368 BLAKE2B 2ce32043fd3371d54b1922f973b9f8b4fc1bd1ace05fb2ee4136ed759454ebc5b3ac34030156d15a72d8e58bd739e7a4bc458e2cb26b8f80e9498df47c857a7a SHA512 263aaf8b466d83215251f6115fa6210bca69537d041336ec23d9caaad06653fe848914c2e01981461fbabb8f5e4881ca11a4a01aaccb07909de6b79e695602d6
+EBUILD nbsphinx-0.2.14.ebuild 669 BLAKE2B 57b04296108b499197f2e6dd3cedd90dfb379aafdf7481afdc9bb1bf5ae5effffe9812c950f85334ddf1b1086a312cb3c0d4eaa0f7dc745bae94e0ae289ef831 SHA512 0a1753f26e22dd30a641dda079a5f99273ff99f9ac0890e0f5a935a68ac76d8e8f1c52be8b7eddebff6b656451d902edd4da92c562bf49eb28883c86f614e2ba
+MISC metadata.xml 809 BLAKE2B 2724ffcef846efed97ee16e7395b3362596c46347fda07bb418469f3e39f06e0523177e7a8bee35cab7113de6380a1b7ca34a6b8bd108e765796fe12d4fcc478 SHA512 03c63397c153886e8ab60767ae510a4d17350a5a2b18c05ddbcc453ef81581a029c3c63fd7c82b109dcbe9a142ec32af1650b240c72d8f95097be326c39a7080
diff --git a/dev-python/nbsphinx/metadata.xml b/dev-python/nbsphinx/metadata.xml
new file mode 100644
index 000000000000..a586fea8a7a3
--- /dev/null
+++ b/dev-python/nbsphinx/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ nbsphinx is a Sphinx extension that provides a source parser for
+ *.ipynb files. Custom Sphinx directives are used to show Jupyter
+ Notebook code cells (and of course their results) in both HTML and
+ LaTeX output. Un-evaluated notebooks -- i.e. notebooks without
+ stored output cells -- will be automatically executed during the
+ Sphinx build process.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">nbsphinx</remote-id>
+ <remote-id type="github">spatialaudio/nbsphinx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild b/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild
new file mode 100644
index 000000000000..2d245d087a3f
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.2.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"