summaryrefslogtreecommitdiff
path: root/dev-python/munch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/munch/files
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/munch/files')
-rw-r--r--dev-python/munch/files/munch-2.5.0-pbrectomy.patch17
-rw-r--r--dev-python/munch/files/munch-2.5.0-revert-pbr.patch39
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/munch/files/munch-2.5.0-pbrectomy.patch b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
new file mode 100644
index 000000000000..13121c345b80
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..62e1ad6 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,7 @@
+-from setuptools import setup
++from setuptools import setup, find_packages
+
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
+- keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ find_packages(exclude=['tests']),
++ version="%VERSION%"
+ )
diff --git a/dev-python/munch/files/munch-2.5.0-revert-pbr.patch b/dev-python/munch/files/munch-2.5.0-revert-pbr.patch
new file mode 100644
index 000000000000..450020cc2c19
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-revert-pbr.patch
@@ -0,0 +1,39 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..9046e38 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,29 @@
+-from setuptools import setup
+-
++from setuptools import setup, find_packages
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
++ name="munch",
++ version=__version__,
++ description="A dot-accessible dictionary (a la JavaScript objects).",
++ url="http://github.com/Infinidat/munch",
++ author="Rotem Yaari",
++ author_email="vmalloc@gmail.com",
++ install_requires=[
++ 'six',
++ ],
++ packages=find_packages(exclude=["tests"]),
+ keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ classifiers=[
++ 'Development Status :: 5 - Production/Stable',
++ 'Intended Audience :: Developers',
++ 'Operating System :: OS Independent',
++ 'Programming Language :: Python',
++ "Programming Language :: Python :: 2.7",
++ "Programming Language :: Python :: 3.5",
++ "Programming Language :: Python :: 3.6",
++ 'Topic :: Software Development',
++ 'Topic :: Software Development :: Libraries',
++ 'Topic :: Utilities',
++ 'License :: OSI Approved :: MIT License',
++ ],
++ license='MIT',
+ )