summaryrefslogtreecommitdiff
path: root/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/munch/files/munch-2.5.0-pbrectomy.patch')
-rw-r--r--dev-python/munch/files/munch-2.5.0-pbrectomy.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/munch/files/munch-2.5.0-pbrectomy.patch b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
new file mode 100644
index 000000000000..13121c345b80
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..62e1ad6 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,7 @@
+-from setuptools import setup
++from setuptools import setup, find_packages
+
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
+- keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ find_packages(exclude=['tests']),
++ version="%VERSION%"
+ )