summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-python/marshmallow
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest4
-rw-r--r--dev-python/marshmallow/marshmallow-3.10.0.ebuild28
-rw-r--r--dev-python/marshmallow/metadata.xml4
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 92b81feb5ba7..7464c2d277ae 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,5 @@
+DIST marshmallow-3.10.0.tar.gz 172801 BLAKE2B 1d1f5d531a9704a9b82170347e2c5dd2b3fd4488204a05f9be7705a39e5a6a42342bcce1438484c22944a6fb4470a731825314ed7ced79dbaf9cc195f049d9b2 SHA512 41520a7cfde483ca06a69e49ab04f8972932d0fbf7a6c75ef568779b55d5f2f666aead4c161e03416e9b90fba71fd73b3f14630f0d7050b8a7fe7a4bb50d5bf0
DIST marshmallow-3.5.1.tar.gz 168839 BLAKE2B 8abf8e8d45d37794c3c615f6dac8ccd0acb76357e92ddaa4c23232b7aefba63db9bd42fb7f13dd99f9ea2ec4c7608459bc36014f9344ab91894176d0f02259c9 SHA512 89b3abce9e31dad6a20cf8ceef62270c8f95cbdf80965b6d29f1728d37d51171a020463da9d0354688183ea07e3f47a0ddab8694da13fe238f11a3dc755d4d6e
+EBUILD marshmallow-3.10.0.ebuild 679 BLAKE2B 0e864a43ccc7b50b784ef2d9fdb075e1063ea04df934f72832cec3ef6ec6e12cc1bcaa2c20e390fe6c356236ee299a9c6a21c0ed7f545a8d41fd05586d2ceeb5 SHA512 555ba06a1fd020262d3364e174c8c5821df03d3e5d537e4eff7ea62acde3f6b7cc3c2ebf987c1a702a85c45221028116ca1fd3c3b2a682340e8bdab81c7f4760
EBUILD marshmallow-3.5.1.ebuild 726 BLAKE2B 64a22029b107e60909be345444282013116723dc4f52cf9628b4c8a2b47607a14db29cda4fb5f1f1c7f06b63519c4d2a0d84cc9e87319b329223dee5e097332a SHA512 9bea4bf43b5018e0f58a240db751b5505c8438305afd9a3fe293c816face9ac1509363041ab13f437d6026d06c26906e877dab7f4790917511ec0a153f7561ef
-MISC metadata.xml 360 BLAKE2B ed1f62630b417aaefbfc1ce52c275f16187a1fac9ee46e7172c4b703452329b64de253eed111bde2e7bcb4b85e7806d8423fd5d80899f93b23e7c3da61030a2d SHA512 51665fe5adb03e70bb1582f393b95783c9e4956c24f664c09d08017663bc8373b07080c142f714fd4c93381cbd5c55bec2b58ca412df6aa55980f9a61abebc54
+MISC metadata.xml 461 BLAKE2B d1723db313f210e554d88a75276965f8f1a385ba8f879d2c43d8875a774240e7db4df6e2cf2a73138069b67a65760b2170bac2ceca8d5cf8681242b01f68d974 SHA512 257a5648aa10d9f8ec87a62e1e090374595256a4cf66f32775be135772114396610ad57e7ddf5274b6ef4755c563bdd3bc364df2751e61b10593d10e12bcb654
diff --git a/dev-python/marshmallow/marshmallow-3.10.0.ebuild b/dev-python/marshmallow/marshmallow-3.10.0.ebuild
new file mode 100644
index 000000000000..7adf1de6ee1d
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/marshmallow/metadata.xml b/dev-python/marshmallow/metadata.xml
index 36de12026687..4398cbd0b3d1 100644
--- a/dev-python/marshmallow/metadata.xml
+++ b/dev-python/marshmallow/metadata.xml
@@ -4,6 +4,10 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">marshmallow</remote-id>
<remote-id type="github">marshmallow-code/marshmallow</remote-id>