summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow/marshmallow-3.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/marshmallow/marshmallow-3.10.0.ebuild')
-rw-r--r--dev-python/marshmallow/marshmallow-3.10.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/marshmallow/marshmallow-3.10.0.ebuild b/dev-python/marshmallow/marshmallow-3.10.0.ebuild
new file mode 100644
index 000000000000..7adf1de6ee1d
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest