summaryrefslogtreecommitdiff
path: root/dev-python/loky/loky-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/loky/loky-2.9.0.ebuild
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/loky/loky-2.9.0.ebuild')
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
index 70165402b043..6a166599dde5 100644
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ b/dev-python/loky/loky-2.9.0.ebuild
@@ -25,14 +25,20 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${P}-libc.patch
+)
+
python_test() {
local args=(
# docker, seriously?
--deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
+ # hangs, and even pytest-timeout does not help
+ --deselect 'tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill'
# one test that uses a lot of memory, also broken on 32-bit
# platforms
--skip-high-memory
)
- pytest -vv "${args[@]}" || die "Tests failed on ${EPYTHON}"
+ epytest "${args[@]}"
}