summaryrefslogtreecommitdiff
path: root/dev-python/loky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/loky
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest3
-rw-r--r--dev-python/loky/files/loky-2.9.0-libc.patch28
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild8
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 8ac20630812f..c35cc67c275a 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1,3 +1,4 @@
+AUX loky-2.9.0-libc.patch 956 BLAKE2B a03de811cb32e728c22b2637106ffd3c969e9fbbbd45deb180ac83d9c44e81b7b5eb0744816abd4a1083d9d47c817db5c02f5f5f6c448f944365299dbd97a044 SHA512 c2e74f96a8f70ec9817cc517fb13ecb8414d6a9157d882ba15af05a81ec70df0edcdb6a8a02c96e7ecc4731813cb86932832fe61b5e19653164af9f7c68dc25a
DIST loky-2.9.0.tar.gz 115019 BLAKE2B 2aa2042e32821b67db8b8de12d4b380d22af93d308bb35878271a4859325d6740a3bdab70b464a2c0d0af143903c8af3da81b4b804605cdae88779fefd7971a6 SHA512 d49354b834251f6f05a689ac44464aafa5a7a5b4a8ef84a308ec3bda138e810fc3dc31aa628307984dc69386a210f442d4c202b9499ae3e3864837b47a5b0cd9
-EBUILD loky-2.9.0.ebuild 878 BLAKE2B 74097796492b0383ed7018a272ac5f683f7f95037000b3ed4016dfb1635c34479f6a6d926b49a3d14dd5a5ada7c64dd4ce423577417be067b2a22a442e4606b8 SHA512 9d8be95852595a33352f71c1ace72e4c6575b45f4238406b1d98e535ea94c3f4809567e0f208da084f3fa36a95c838e6b42ebef4fb245b0d082dfe29644ecfd0
+EBUILD loky-2.9.0.ebuild 1021 BLAKE2B 2ea8aee9ab4b527a6e72b4f7a6cc7797f1da8ccb265911fa954bb986d8202981038788cfbe10333948de7887d845a4bbc4aa10b13fbedcfe0b871fd99ae979b2 SHA512 503f67e0cde83f3ee71efd5bf66a03cd9770f418d84babc5c5be4ce3492a803415c60504c45140e6802fc2f4a416c5d7ddf483ac8692ede8c3a59361d29854b4
MISC metadata.xml 285 BLAKE2B 0a3a6c5d0dd5f4ba9ee472ae8d58d5ccc0c0a4677793e1b0350193fce534d96513ce5b16610e90ba5f8cd3cb71e03db6c45566e1d55ebc5fb52bf6f30b740d66 SHA512 ab759fe515785fa9dfc92ed5e3e71e67b32eea0f7c1d0ad7165bc41713e8345ddc04549bb771dd92973365ceb53b4465fdbad914b4d1f7f76232e278edec2577
diff --git a/dev-python/loky/files/loky-2.9.0-libc.patch b/dev-python/loky/files/loky-2.9.0-libc.patch
new file mode 100644
index 000000000000..58cceab01eb2
--- /dev/null
+++ b/dev-python/loky/files/loky-2.9.0-libc.patch
@@ -0,0 +1,28 @@
+From 4100bb481dd1599be3deae8539ff9eac2d9b7104 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 8 Mar 2021 10:32:38 +0100
+Subject: [PATCH] FIX load libc correctly in test_reusable_executor
+
+Fix test_reusable_executor to load libc via "c" library rather than
+"libc". The latter is incorrect, and does not work in the newest
+versions of Python anymore, see https://bugs.python.org/issue42580.
+---
+ tests/test_reusable_executor.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_reusable_executor.py b/tests/test_reusable_executor.py
+index 1ff5b8b..d24d2de 100644
+--- a/tests/test_reusable_executor.py
++++ b/tests/test_reusable_executor.py
+@@ -32,7 +32,7 @@ if sys.platform == "win32":
+ else:
+ from signal import SIGKILL
+ from ctypes.util import find_library
+- libc = ctypes.CDLL(find_library("libc"))
++ libc = ctypes.CDLL(find_library("c"))
+
+
+ try:
+--
+2.30.1
+
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
index 70165402b043..6a166599dde5 100644
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ b/dev-python/loky/loky-2.9.0.ebuild
@@ -25,14 +25,20 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${P}-libc.patch
+)
+
python_test() {
local args=(
# docker, seriously?
--deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
+ # hangs, and even pytest-timeout does not help
+ --deselect 'tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill'
# one test that uses a lot of memory, also broken on 32-bit
# platforms
--skip-high-memory
)
- pytest -vv "${args[@]}" || die "Tests failed on ${EPYTHON}"
+ epytest "${args[@]}"
}