summaryrefslogtreecommitdiff
path: root/dev-python/logical-unification
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 11:36:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 11:36:18 +0100
commit6e88bac8dd26372eea042112ad3769b1fac9ae18 (patch)
treee8694d56fbae41e2d5f4025730db56041463d94e /dev-python/logical-unification
parentc59fc2181f7402f8d0a548bcc897584a83139cc1 (diff)
gentoo auto-resync : 07:05:2023 - 11:36:18
Diffstat (limited to 'dev-python/logical-unification')
-rw-r--r--dev-python/logical-unification/Manifest2
-rw-r--r--dev-python/logical-unification/logical-unification-0.4.6.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/logical-unification/Manifest b/dev-python/logical-unification/Manifest
index 8555d41c4260..9ffd12e51322 100644
--- a/dev-python/logical-unification/Manifest
+++ b/dev-python/logical-unification/Manifest
@@ -1,3 +1,5 @@
DIST logical-unification-0.4.5.gh.tar.gz 47003 BLAKE2B 9f7e119a69b15b460ce66af137a3f0c3dd3da154173ac196a94d4894aafc67eeaa31d69c5ca8bdd6e264a3f7599f9e301dad103510c77e60ff14cc8af1c86ce8 SHA512 42af33ac7da6013d48d26ab49b84b40146f494963f1eee06256a219e8d0517b04cc3fe86f51cf19729fc64ad765e75a4890b278c2dbbf34eb7e1ef65f3014784
+DIST logical-unification-0.4.6.gh.tar.gz 47171 BLAKE2B 894db9bfc94b1b4ed496376bb45dd6f71db89f57ff73ab4bfacd12e991817751c4213b36d6e19d34b239e1335dcbe7b71ab283d419bab92554dacc539355ae7e SHA512 6caf91823acbaf0341d7d515610bbe351882f1b6fdff064fc900adb56387c6023a49743b0ad5f6f1c6af42e79b53ac1d1540a4ce3c42dca5fd79f0abec9f653c
EBUILD logical-unification-0.4.5.ebuild 697 BLAKE2B 4b5c5042e65226600567bb9341912614d92d5ccdf02bd2da36fd341cf6eca564f6ac168da2b3eed1f220ed34fef46b413c2038c2d2e2232667fa298840caf20c SHA512 aff4477367ed6aa575cff24b240dcf87c1c8bdd8c8db318b09aa3a003346947f72f07cc5302cd936cb9da2ea1f83a4abde03f9142800b820158faea42940364a
+EBUILD logical-unification-0.4.6.ebuild 765 BLAKE2B 99d3ac3826ef004344925ead29bd13e1bd8a2fc7bb40c9049bacbf32762d562acb2a128638f99d626a22384a52d0f57b408a0a904fe28088538b082c98d28219 SHA512 3a3f13822f538e2e57d491222f20a686f359c60c57498c6c0f6d754e2587cb39ae2b4b55c6d52929ee00071254dfd4b571adda043f5dc5d3812868cb7ca2d598
MISC metadata.xml 411 BLAKE2B 41b22447e02d0d7cb7b13523abafe18bf4c01033ffe561c022d32c9896fe85272a1357682b678e0d679d01d992cdef1e445358280c581dcc1071a6e7b1f7e587 SHA512 21e61a22962dd3b4eb70efa40e2dd74660c540f79e13a3d9015494681432361f660003b3fa533fdd82faeb1e76bd4486c40478c99076e65997da14de1c0d8315
diff --git a/dev-python/logical-unification/logical-unification-0.4.6.ebuild b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
new file mode 100644
index 000000000000..a4d2f2079412
--- /dev/null
+++ b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Logical unification in Python"
+HOMEPAGE="
+ https://pypi.org/project/logical-unification/
+ https://github.com/pythological/unification/
+"
+# No tests in sdist, as of 0.4.6
+SRC_URI="
+ https://github.com/pythological/unification/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/unification-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_benchmarks.py
+)