summaryrefslogtreecommitdiff
path: root/dev-python/logical-unification/logical-unification-0.4.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/logical-unification/logical-unification-0.4.6.ebuild')
-rw-r--r--dev-python/logical-unification/logical-unification-0.4.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/logical-unification/logical-unification-0.4.6.ebuild b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
new file mode 100644
index 000000000000..a4d2f2079412
--- /dev/null
+++ b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Logical unification in Python"
+HOMEPAGE="
+ https://pypi.org/project/logical-unification/
+ https://github.com/pythological/unification/
+"
+# No tests in sdist, as of 0.4.6
+SRC_URI="
+ https://github.com/pythological/unification/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/unification-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_benchmarks.py
+)