summaryrefslogtreecommitdiff
path: root/dev-python/lit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
commit51f0d16e058c162dbce0f93d871ba45683b0ab3a (patch)
tree8dd3bc53a0d23549a8f210ce4bfdf74b36b9319f /dev-python/lit
parent35bf81c760d4e362615c32e69329ef61a01281f7 (diff)
gentoo auto-resync : 06:08:2022 - 02:09:04
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-16.0.0.9999.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
index 231cebe2df08..39b1c5db60b3 100644
--- a/dev-python/lit/Manifest
+++ b/dev-python/lit/Manifest
@@ -4,4 +4,5 @@ DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69b
EBUILD lit-13.0.1.ebuild 907 BLAKE2B 786bc45254014c19e47997b263eba9245fc44459a6f12d46e69803fdf57c1b8f3d07d7e0354ea23ab17471771f57af8e792ca942b9f195462a26629d8d6bfb8b SHA512 ca254f8d0d3af0e01b24e73de8e15b77d687fd0f23a4848dd4e85522426e7dbdcd8ae77e25d8f88e637e390131fe78362ae7ba4ecd192a4c970cc3311b371dfa
EBUILD lit-14.0.6.ebuild 914 BLAKE2B 80f1bb1010f71ff835aef8e87cc0bca5de0dd97e74debaee4e26d698e530468b755bc632884c11616a0ae082befa75a7b6c11043c70c3bb5679b0dae1c985d0a SHA512 77eafef2378be28fdcaa87f07fec8b1907f8c491b4a600b47d9f5970148f6684e6b4733ad6dafb753aa7a56ed1834b10ff30afc5995812c895749ea0c7294e47
EBUILD lit-15.0.0.9999.ebuild 871 BLAKE2B 5ab6cc094e95685501304ebac41e07a919505fb6ce9b2db04e0c671e6a494df35ba81f6a43d8448cb2f94e982e32850658085daa98ca60e652da887dffc400a6 SHA512 d4cf8c7c2bc71376c998ff0d9796c6713b20e972014f13369d7658667f23cd97ec237df2818aa96add88cb4e2c36d1f272494fbab8d6b15014d5529d95616186
+EBUILD lit-16.0.0.9999.ebuild 871 BLAKE2B 5ab6cc094e95685501304ebac41e07a919505fb6ce9b2db04e0c671e6a494df35ba81f6a43d8448cb2f94e982e32850658085daa98ca60e652da887dffc400a6 SHA512 d4cf8c7c2bc71376c998ff0d9796c6713b20e972014f13369d7658667f23cd97ec237df2818aa96add88cb4e2c36d1f272494fbab8d6b15014d5529d95616186
MISC metadata.xml 340 BLAKE2B c9ca851e49b4ab48c015686e983ec988f60c34ed0af77abd7bc03d046002f79f74b9b463ecb97db89f2230c1593af7acdaf6651fc51fed4aa92a459d07aabf18 SHA512 3fe8262ce6b971364162fbdbac3b02bf02f0a64896c8a2564e2a2998bd6e6bc74463bf9104e3f4ffaa9f5c1a16c877fc864b8a4f056ca0022f741799bc00f217
diff --git a/dev-python/lit/lit-16.0.0.9999.ebuild b/dev-python/lit/lit-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..8ace6ca8b915
--- /dev/null
+++ b/dev-python/lit/lit-16.0.0.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}