summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
commit51f0d16e058c162dbce0f93d871ba45683b0ab3a (patch)
tree8dd3bc53a0d23549a8f210ce4bfdf74b36b9319f /dev-python
parent35bf81c760d4e362615c32e69329ef61a01281f7 (diff)
gentoo auto-resync : 06:08:2022 - 02:09:04
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin257767 -> 257788 bytes
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild47
-rw-r--r--dev-python/libtmux/Manifest4
-rw-r--r--dev-python/libtmux/libtmux-0.13.0.ebuild44
-rw-r--r--dev-python/libtmux/metadata.xml1
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-16.0.0.9999.ebuild42
-rw-r--r--dev-python/pylibmc/Manifest2
-rw-r--r--dev-python/pylibmc/pylibmc-1.6.2.ebuild61
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.9.1.ebuild96
-rw-r--r--dev-python/svglib/Manifest2
-rw-r--r--dev-python/svglib/svglib-1.4.1.ebuild38
14 files changed, 340 insertions, 1 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 8ad09bf0b63f..4200f643acb6 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index 2b39984efb29..996d649e2922 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -4,4 +4,5 @@ DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69b
EBUILD clang-python-13.0.1.ebuild 925 BLAKE2B 1dab0cbb672643072e7d824a262c81505d19e555f24f97f82156473affc2f5ba6fc34ec493ffeedbc82feb1245fc6a39126e1b81fcdc8f8b4ddd0b7fe108e4bb SHA512 11eaf5c7a484d756f01986eacce19c912666518892f3213ff42367c126c2d8474abf6608cca24e6250c64e7423464e7cb3e58c2b069c7febf4893b249f2ee304
EBUILD clang-python-14.0.6.ebuild 956 BLAKE2B 491c8335c64484034663fd84ca2397e13afdd8cab6d3b4adfcc9317379e7a3620372ffe5996d4a0029a7d412f11a0d598f741a6893803ebadba85d330e49682a SHA512 4ef0d1ab2cbc3d277d4cced33fa87de7c3d43295a60a3b418ad4a95399e8de8c2e1e5c594681bf7ce1bfc465732d34b2db3a9e8636c0ed124ddf79c8ed7a5750
EBUILD clang-python-15.0.0.9999.ebuild 935 BLAKE2B d1b871cd5604ded49427be7bbd4453b30b11515c6befc0d4202bb5602c387e41b789a6e14eebefc2a55723a1b4f683a82d41de4bdcbbdfdd85117f5ce64674c4 SHA512 e55abe1dfb64dc1d85c564013d1a01da128cbcb252aa118529ef61b8f0f17a0ae8653ef757a0b59f1b7d45e887951fdcc242bdc1cedaf9b1628047e4a33678cb
+EBUILD clang-python-16.0.0.9999.ebuild 935 BLAKE2B d1b871cd5604ded49427be7bbd4453b30b11515c6befc0d4202bb5602c387e41b789a6e14eebefc2a55723a1b4f683a82d41de4bdcbbdfdd85117f5ce64674c4 SHA512 e55abe1dfb64dc1d85c564013d1a01da128cbcb252aa118529ef61b8f0f17a0ae8653ef757a0b59f1b7d45e887951fdcc242bdc1cedaf9b1628047e4a33678cb
MISC metadata.xml 299 BLAKE2B 2feead2cd1b35b3a43335ddd7711f8181b52bc63ee7166608914260c67528add5251349063afbef4f8cf0ec09b2cd4c3ffdd90f2c14ed60bb69ebc03888f6333 SHA512 cd745c54ab18d25bdaff18582105072574103a36cfe7c175ef740f266d00e9fc6f44c332904d23b911c939cf5bdf52973b388923099d8dd5dfef3c283b5cb685
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..2891edc42793
--- /dev/null
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index d0fd7a13c0b3..a4c5d7d0e8f7 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1,7 +1,9 @@
DIST libtmux-0.12.0.gh.tar.gz 214161 BLAKE2B 7040da2ee782b2e6bc73c70de0f5d5713c989a0959b0e731ac060f442e82e99829689f924cc2aeef6e79339b4f419df4143e2d5a9e356ad27cccb9cb3802e2f2 SHA512 f6f80daa3aaa99dd81ec0eb6a119ab1ad5fcd6c656d280b06a40c2b3bdc8d3ca7ae06089ea74482bfff005997f07e346338330d9ecf1c6745a6f3b7719b9cd0a
+DIST libtmux-0.13.0.gh.tar.gz 240339 BLAKE2B 5b975bef4835ed8b74f05fd56bd824028fa64b56c700396d0387661cdf41a4a43d81dce10462c89a90ce352b00ca0fea0334fa02e7259464a62369637b2435ce SHA512 bc5fce8c201f7c69fcbc15605808544baf19896e51c44daeebc4c133ee1db70dbffa8eea2641862cf27ca9fe341f4721cde432682e5aea84b2573f83ad25555f
DIST libtmux-v0.10.3.tar.gz 225258 BLAKE2B 40d591ee1f8a6068947b61416d6247b2475cc99031a67c167dc527631e50075f18c46fe6fc16193867d83a1a735b0a23fbfbc77f4539f788f05375f1f68b77d2 SHA512 2c8f28ce8c313404caffa42e5fd4a1dfa5d48bdc48203f8db595cb97b44886d63608771f23d62d76a56513b7e4578e48a31cacd224eca92425f110efd0a5db69
DIST libtmux-v0.11.0.tar.gz 234278 BLAKE2B 4939d38894fd6a1492ff282c98243b2d5b3b6f787691031c74337629aed710d3caebeb3bfce571e8f38fe07ecc341b6b3f8aa0bc42979fa362f5f0679aabf21e SHA512 e09749ce4cf7cf7756e4e40e50c6eb0a00435f2b00c8436667b6b77a94078e9c380a811107f8129ea0d347355f3ce8bb213b8fb36de2becf3cf1a2dbebd97867
EBUILD libtmux-0.10.3.ebuild 905 BLAKE2B 63b12c494a018b8ccbb0d25fe97a5c67c8ebc7b5df0cc9d92c254fa245409f4f08fb8d45875a3595b81faace65d3b37b40eaca939768f4910781625cb5ccc2e6 SHA512 ab794fc256e2a17ffbfd3e2fca12cf69f804cd1abee07ffeaab1dfbd80b189da8b3f8633dfa755d026d4c8b5ec5444aca9350ab33384d75e03d08d01a3cea198
EBUILD libtmux-0.11.0.ebuild 893 BLAKE2B 78bc71ad81e503f26119b443e82d83b99c63d55cf07186f831cb881bce838b040158b438b94f59b833aa58e5e7eff143ef64ece236bfb7df87f71f14dc20b2ed SHA512 63c6488f01a2f4a8fec27b6ee383f5d1493ccbd7e54522a951f2d6613247009364194e381c9f0698337d7b19a20907191bce49eeae232bcd934d3a659a6f4152
EBUILD libtmux-0.12.0.ebuild 896 BLAKE2B fff952326f8be9a0c87ec6668ab8dcbc090bcca65e1d1f07bb6155ba57c1fa55e3ab23312226bae66bb439eda537acebd29af29e71b54976ce7bc49402604d28 SHA512 5174b8e419f5c72b6e29ed676e5ac083d23cf41e57d7bc02eecc9a222842cc364c711bf408cb7f0fb66dc70c1ec6f7de833d51d0a423b08aedbb1063865aa493
-MISC metadata.xml 344 BLAKE2B 08a7a60065c53319e73c36fc0f43bd3a98e02970588c2a83de3a429c82d68950f37b151d66c6adbdfa16f638e80ea6e8221d927e02cc6180fa40a6b0952b9ec0 SHA512 2d73a227ab73d3fce031c68e8c7f700f29ffe2ad1b0efba89afa854737de70e91d4fc9efae6a87459e420703c893a90d97b537f745f43df1181ccf26430d0a95
+EBUILD libtmux-0.13.0.ebuild 979 BLAKE2B 992f0bab62635f4304d01ae890ea09036d2e179761617f20ab858376e1c36bcdd16da492e11ebc1ea7cace6ef844ce98fef04c8d2439252e64a9bbe4773d8714 SHA512 78c560b8aa1d948aa2ce76eecb5686abe2394317c73c73294b0fa3fc0a9f7b69da1a2193f209ac9796ff5189ba666f39e34240bad40603f1a3112809d82ebb57
+MISC metadata.xml 403 BLAKE2B 68af7251349c8999bbdbfb7b55ca4632f8752468d7e478fd985097af86d00afe93b231667a25e3c997a3bc86b708d4e6d6ef5c35a783871cdc83519fc1db1ab1 SHA512 2a88df695e94f1da966bb72f7e90d00f2e343e40fe1924837f8c087dfc9a9a84fe0b2909a98f2f41ba72f6ba01796888a80cbac3f1bf9f05984a06385037d977
diff --git a/dev-python/libtmux/libtmux-0.13.0.ebuild b/dev-python/libtmux/libtmux-0.13.0.ebuild
new file mode 100644
index 000000000000..4dce1d6a69c4
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.13.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="
+ https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/libtmux/metadata.xml b/dev-python/libtmux/metadata.xml
index 76005c5215ab..1bbfe598fa7b 100644
--- a/dev-python/libtmux/metadata.xml
+++ b/dev-python/libtmux/metadata.xml
@@ -8,5 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">libtmux</remote-id>
+ <remote-id type="github">tmux-python/libtmux</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
index 231cebe2df08..39b1c5db60b3 100644
--- a/dev-python/lit/Manifest
+++ b/dev-python/lit/Manifest
@@ -4,4 +4,5 @@ DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69b
EBUILD lit-13.0.1.ebuild 907 BLAKE2B 786bc45254014c19e47997b263eba9245fc44459a6f12d46e69803fdf57c1b8f3d07d7e0354ea23ab17471771f57af8e792ca942b9f195462a26629d8d6bfb8b SHA512 ca254f8d0d3af0e01b24e73de8e15b77d687fd0f23a4848dd4e85522426e7dbdcd8ae77e25d8f88e637e390131fe78362ae7ba4ecd192a4c970cc3311b371dfa
EBUILD lit-14.0.6.ebuild 914 BLAKE2B 80f1bb1010f71ff835aef8e87cc0bca5de0dd97e74debaee4e26d698e530468b755bc632884c11616a0ae082befa75a7b6c11043c70c3bb5679b0dae1c985d0a SHA512 77eafef2378be28fdcaa87f07fec8b1907f8c491b4a600b47d9f5970148f6684e6b4733ad6dafb753aa7a56ed1834b10ff30afc5995812c895749ea0c7294e47
EBUILD lit-15.0.0.9999.ebuild 871 BLAKE2B 5ab6cc094e95685501304ebac41e07a919505fb6ce9b2db04e0c671e6a494df35ba81f6a43d8448cb2f94e982e32850658085daa98ca60e652da887dffc400a6 SHA512 d4cf8c7c2bc71376c998ff0d9796c6713b20e972014f13369d7658667f23cd97ec237df2818aa96add88cb4e2c36d1f272494fbab8d6b15014d5529d95616186
+EBUILD lit-16.0.0.9999.ebuild 871 BLAKE2B 5ab6cc094e95685501304ebac41e07a919505fb6ce9b2db04e0c671e6a494df35ba81f6a43d8448cb2f94e982e32850658085daa98ca60e652da887dffc400a6 SHA512 d4cf8c7c2bc71376c998ff0d9796c6713b20e972014f13369d7658667f23cd97ec237df2818aa96add88cb4e2c36d1f272494fbab8d6b15014d5529d95616186
MISC metadata.xml 340 BLAKE2B c9ca851e49b4ab48c015686e983ec988f60c34ed0af77abd7bc03d046002f79f74b9b463ecb97db89f2230c1593af7acdaf6651fc51fed4aa92a459d07aabf18 SHA512 3fe8262ce6b971364162fbdbac3b02bf02f0a64896c8a2564e2a2998bd6e6bc74463bf9104e3f4ffaa9f5c1a16c877fc864b8a4f056ca0022f741799bc00f217
diff --git a/dev-python/lit/lit-16.0.0.9999.ebuild b/dev-python/lit/lit-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..8ace6ca8b915
--- /dev/null
+++ b/dev-python/lit/lit-16.0.0.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}
diff --git a/dev-python/pylibmc/Manifest b/dev-python/pylibmc/Manifest
index 2645742108c3..d914f5f0a9fc 100644
--- a/dev-python/pylibmc/Manifest
+++ b/dev-python/pylibmc/Manifest
@@ -2,5 +2,7 @@ AUX pylibmc-1.6.1-fix-test-failures-r1.patch 516 BLAKE2B b471ca80b11beff5ac0119f
AUX pylibmc-1.6.1-py311.patch 918 BLAKE2B dcc8b3a8c8cc6d7a2b8de79af116ed55171a968b6a8da89b96041e70232e239ff6eacb3a4ad8794fc951e34e71e9b142adfc8ddb689336d559f989e219e1a936 SHA512 fedb103ee4d392f21c4b8f4ce7d3fafe8e3c0d9aa8b2ce464cae5e7553fc3a9ec1fb82d085106faeca448df54d3636ec38c296682d9e49b097c9bd06e76a02b1
DIST pylibmc-1.6.1-no-nose.patch 26090 BLAKE2B 160e5b58107dcea0354462370eeeb12739c7fd1549e1c64ddf1fe2451654e50c1408505985eb6a7150ce60185bc7acebba7a20c6444615bef8c6991debfba4cc SHA512 84fb37505def84caaacb1343032d18bd644f5072e6ce7a2d6e88bc33bd2dedc8b303f4cf2a9b57b32c3c4b8e01bef1bebcc09ecb525568c928aed326bee2cace
DIST pylibmc-1.6.1.tar.gz 72061 BLAKE2B ebaa6f9dfc341d862a8b46bbbf0db1420ff400cb40390f7bee6bf198ff941ad7967b578040ffe1209721ea84a163a39649108a2a23f3dadc2d579db740b2ccf3 SHA512 a3874435389486b29bab5f1d29e5c179d67655d90995bb27fcb7cd46ce7eb3b60117b94f901602f8a65dc0e587d5f8edfcf15e259effd439411adb58ddb7065e
+DIST pylibmc-1.6.2.gh.tar.gz 71581 BLAKE2B 4fc9216150e122b6d80537184422b52c0a518f5b9fbcf5b54f794fde33d5ac6fcd474e08f71b8d71f0443351e91ea5d8ac2c24e94bd568605cf1183259394091 SHA512 1a1575fd5c3644d53e0ed49818bd958e0e28fe0354f41578c944b260f402f1b51a74baca8f98b32adfd0024e61ec8df1795c6ca7363509e35e4f34a907de063e
EBUILD pylibmc-1.6.1-r2.ebuild 1383 BLAKE2B 722b240fc8e21ef8ad8007d788937c130159080dbc4f6da82a7b7fffc620c9f9945d2c6f330515b17eaf3124738386ee91c8a159743450f711ba281697baab1f SHA512 5b7fbaa7198f7a0eac192607d51a118ab3a1251f017c303ee0f92743b02e83fdc34a795573d821baeda02685a0a19ca02f9784f14c86b0ad67009ef8dd072e21
+EBUILD pylibmc-1.6.2.ebuild 1234 BLAKE2B a2b45998533c4b68074c5e58406a68a4cbf6574322cc0e29163164ced280ee9c15306b1b733db710c18c240adb604979e40806525192182de17d79140f755138 SHA512 99049e42ebb1aeca7c456cc5068fcb9e24d0a4ba7a94099622480ba92905323b2beff1a598788c0a9b6ed15354cb8472027f284d68c091550c3f365b4ad2c9a2
MISC metadata.xml 367 BLAKE2B fd37f3e072661e616dcfabb2054827a7b1c3830e555cb6fa461e93dadcd39ab1856c0ad4cbe03be85924889b97ba7cc88da651011a4b1c5622fcd950339f7e2d SHA512 33977c15a726c2039221bcbd282244c240013922bd4f1398e75f01ebd68dd0f8574ac890ddb578cb633a89b52584927800f86dcb4a1eb0ab27b165c38b9a91e6
diff --git a/dev-python/pylibmc/pylibmc-1.6.2.ebuild b/dev-python/pylibmc/pylibmc-1.6.2.ebuild
new file mode 100644
index 000000000000..b37179120315
--- /dev/null
+++ b/dev-python/pylibmc/pylibmc-1.6.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Libmemcached wrapper written as a Python extension"
+HOMEPAGE="
+ https://sendapatch.se/projects/pylibmc/
+ https://pypi.org/project/pylibmc/
+ https://github.com/lericson/pylibmc/
+"
+SRC_URI="
+ https://github.com/lericson/pylibmc/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/libmemcached-0.32
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ net-misc/memcached
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/pylibmc-1.6.1-fix-test-failures-r1.patch"
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+# needed for docs
+export PYLIBMC_DIR=.
+
+src_test() {
+ local -x MEMCACHED_PORT=11219
+ memcached -d -p "${MEMCACHED_PORT}" -u nobody -l localhost \
+ -P "${T}/m.pid" || die
+ distutils-r1_src_test
+ kill "$(<"${T}/m.pid")" || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require "AmazonElastiCache" running
+ tests/test_autoconf.py
+ )
+
+ epytest --doctest-modules --doctest-glob='doctests.txt' src/pylibmc tests
+}
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 7d7d354946d7..e08bbafe0c80 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -2,8 +2,10 @@ DIST sentry-sdk-1.6.0.gh.tar.gz 249637 BLAKE2B c4d6788c80184ce9127ed85dfb5305363
DIST sentry-sdk-1.7.2.gh.tar.gz 254370 BLAKE2B e65b2236bfec9279a4aa05b77c9492547f657e461a7c96c4158acb6bc0887571186bfa71893dce34251ef8d783fb5d583b25aa12539c5db7993cec65fdf05229 SHA512 9fe2c283a326b78c8be95500e4916bb633dc7369960a4e0ef69c0f29de74c38db81f43b3931c47d50431ee7f1a66a2b18e8c4fc02ce71c404a5e9700644cb76c
DIST sentry-sdk-1.8.0.gh.tar.gz 286488 BLAKE2B d47f33a1c83cfffa6e4a801a6fdfde132d4cfe1b734e464c4db60e97abf53ebe503c53c3edd89d1a84e655a348a4463a75c3475d4824d03cd9b95733b13b5532 SHA512 aa3be96dbc55265f17371d8f20f8b3116b4310cbc1d078b62beeb1fd90bdbb840db85c25309e16f793a188d373c6dbcfd11a104db21b60221a5fb06d8deacc2d
DIST sentry-sdk-1.9.0.gh.tar.gz 290271 BLAKE2B fcb4c45c129faf23a1177167e2bdd567a7ff228abbaa782676abb16c29e9c4cccef89f67ae5cd28c4f2b25e6687152fdc5eab0c7d981021a8df16374dc4e1fec SHA512 4f287bad8e9dd8eaad8f8a31d7335ccf6bfe72cc0ba8c0b26abcbd7e326bad886709d001976966a7b917f39e1ca249fa881abf29778cfd4bd65c63f05a6f6ef2
+DIST sentry-sdk-1.9.1.gh.tar.gz 270398 BLAKE2B 66ee16816d312b38df737c5ecb0ecc4a2189c932c162bbedf165f2a153029e95c389372a4638d5f71f669ac780710769e4708c3e7673573d1b1e79a29cbf93c9 SHA512 5997252aeee900125e42d7275627359ca5382707162b93e45b238c11a181ac724fea327fa1b29deed63dbf800463d10c9d2a8e8943c32b907e4eac055e399297
EBUILD sentry-sdk-1.6.0.ebuild 2870 BLAKE2B 1bf7978f3df6c64385e0010c8a65d7c3422ac8f7180b2507afa688b739bd14df2cd53ae698e8f5f0b25f5203ec4e1fd6eeae33cb4b75358be2490ddedda13fe9 SHA512 2b4657cd4b1076cfba36034608506e6bfe7d930e5e7db4641ff2f56602741f88be40226581371ca1b18ed35d612341038b9f9ebd16cec427baca18816d34caa6
EBUILD sentry-sdk-1.7.2.ebuild 2874 BLAKE2B 499f352134ac1748e95c5b690a7b3848a4cfca4d532388ab4c056d8b59e37885faeed409c50d2764907280dfc83f2a015a72420f5620724026d7f418d1884040 SHA512 4ffa0cd99c29794138a199ab295e32817ea7fe8c7383a6f68598cd77c992a5ad7782bae3db5e52bf074351e061a2ebd3ab49f9123858e438a813627a82511cdb
EBUILD sentry-sdk-1.8.0.ebuild 3125 BLAKE2B dc87ed38983d2d0affd1cf18b3acdc0c2ae6f4b0105cb24d72afa4d19b20df8da823264821974b7b5ac21a8559bbf617f118b4045a09cba8fc923d6c0cd0086a SHA512 d15338c869daa70b9d834305246fd9add6988909c4192b6137fcc38a950e75c9280e2d5190c14ffdfaeb6256117d34189f31ce1d8fe305fb905cb3e3d10be8ac
EBUILD sentry-sdk-1.9.0.ebuild 3205 BLAKE2B cc50ae93fdb72f81c15ac975cb7359056feba2eb1f67b77335892f784be8f859bc5125fc341f370eaa4b1b3526387fb12246046b1b0d9db52d364f796c440236 SHA512 e78cbc57645b20a02a691cca4849f9728d95eaa10fc55ac035111b50b24b1d8766875a66db0306256b446c2a47a797d2d890ed11ffc1246e6cea43e243b97379
+EBUILD sentry-sdk-1.9.1.ebuild 3205 BLAKE2B cc50ae93fdb72f81c15ac975cb7359056feba2eb1f67b77335892f784be8f859bc5125fc341f370eaa4b1b3526387fb12246046b1b0d9db52d364f796c440236 SHA512 e78cbc57645b20a02a691cca4849f9728d95eaa10fc55ac035111b50b24b1d8766875a66db0306256b446c2a47a797d2d890ed11ffc1246e6cea43e243b97379
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.9.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.9.1.ebuild
new file mode 100644
index 000000000000..9d1e2042e8f2
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.9.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # requires python-multipart (TODO: package it)
+ tests/integrations/starlette
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+)
diff --git a/dev-python/svglib/Manifest b/dev-python/svglib/Manifest
index 33e8ce97f9e5..cf7e7eade8a7 100644
--- a/dev-python/svglib/Manifest
+++ b/dev-python/svglib/Manifest
@@ -1,3 +1,5 @@
DIST svglib-1.3.0.gh.tar.gz 1264820 BLAKE2B f53bda781479ddc5d4b04fd122b5141620db81756308973cb283957615711e62623baa74b69af954936be24970a4e4a6f026667c4069d62bf1705a839ecc52f3 SHA512 457fb69ba1c298079888f200502c7099cf5ee674857ff8682948011bf8e1544715e6196544212f5c0ddef1202d04f3f05d01edb4351e673ceae16a85ca0d66e5
+DIST svglib-1.4.1.gh.tar.gz 1265260 BLAKE2B ad4d6a402cd56e2e6f1fb534a8cc9c2bdc038fbdd01aad228d0b6471fd9781bcec88064dd6b93ef324201f141202404d25e31834c0f32a40c0a8037be7196edc SHA512 058aae53224cc590d56585a0f5e45506bd6586f70ddb3d9429052c8b2c18a3906925cd17a19c0f6b46695159eee1914f5e658293e7c40c1a7506f2414f8c41f8
EBUILD svglib-1.3.0.ebuild 854 BLAKE2B 8b980d7056d29a7174e92605d345cda90495febc4a9e55f3bd326f3ff44cd444bdfdd43da3904b445b3945c12ce36cc117767ce25c7401e8e7d170f33075b6a0 SHA512 4701a88800bd479183b9b84152d5ca82dbb687e76434df028a38133753296819cbe78c642af81a9040645cfad25cb27f7b2109b8f1610626c58bc6095ef16a49
+EBUILD svglib-1.4.1.ebuild 854 BLAKE2B 8b980d7056d29a7174e92605d345cda90495febc4a9e55f3bd326f3ff44cd444bdfdd43da3904b445b3945c12ce36cc117767ce25c7401e8e7d170f33075b6a0 SHA512 4701a88800bd479183b9b84152d5ca82dbb687e76434df028a38133753296819cbe78c642af81a9040645cfad25cb27f7b2109b8f1610626c58bc6095ef16a49
MISC metadata.xml 389 BLAKE2B a63a478393f24f78e31793e4ec841749fb600c0d4ae0b71dfb0f63dbd23fdeab7cb531f4e287d97c1b5f65decd8668cabe42eee6f1fac92f40f203a8cc500a70 SHA512 71a266a3fe1432a966fa52a691f1472f269a04e413c52abc7c7264f9acc233abe6ca86c44f35051fb960a7805c62e2ae12ec6e9799e25b2e89f401c6972c15f6
diff --git a/dev-python/svglib/svglib-1.4.1.ebuild b/dev-python/svglib/svglib-1.4.1.ebuild
new file mode 100644
index 000000000000..b7b7af262730
--- /dev/null
+++ b/dev-python/svglib/svglib-1.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python library for reading and converting SVG"
+HOMEPAGE="
+ https://github.com/deeplook/svglib/
+ https://pypi.org/project/svglib/
+"
+SRC_URI="
+ https://github.com/deeplook/svglib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ tests/test_samples.py::TestWikipediaFlags::test_convert_pdf
+ tests/test_samples.py::TestW3CSVG::test_convert_pdf_png
+)