summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/lit/lit-11.0.0.9999.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/lit/lit-11.0.0.9999.ebuild')
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
index c9394c7a1190..b9123ef7bf14 100644
--- a/dev-python/lit/lit-11.0.0.9999.ebuild
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6..9} )
-inherit distutils-r1 llvm.org multiprocessing
+inherit distutils-r1 llvm.org
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -34,6 +34,6 @@ src_prepare() {
python_test() {
local -x LIT_PRESERVES_TMP=1
- ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
- -vv tests || die
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
}