summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/lit/lit-11.0.0.9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/lit/lit-11.0.0.9999.ebuild')
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
index 611b8345f354..c9394c7a1190 100644
--- a/dev-python/lit/lit-11.0.0.9999.ebuild
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
inherit distutils-r1 llvm.org multiprocessing
@@ -27,6 +27,11 @@ BDEPEND="
# TODO: move the manpage generation here (from sys-devel/llvm)
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
python_test() {
local -x LIT_PRESERVES_TMP=1
./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \