summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-python/line_profiler
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest4
-rw-r--r--dev-python/line_profiler/line_profiler-2.1.2.ebuild30
-rw-r--r--dev-python/line_profiler/metadata.xml4
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index a84389fad1cd..6140951cbb1b 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,4 +1,6 @@
DIST line_profiler-2.0.tar.gz 68478 BLAKE2B fb814b251e8f18a51e65297e57523b85c55b4060444c42d99801aa88c8ee0279abf14def6ecd5a9b09550e46e2d27b3ec809b1333725b00de64b58f117c76ed7 SHA512 c0335fc69fb47c150fa5555af4f7fdf4b172ca12ee6512e04ba854c4a81f3e6ee5594e484d11c8ea7e9e8048e3f3b8661db52332d4ac645195a0e050acea4ecb
+DIST line_profiler-2.1.2.tar.gz 83131 BLAKE2B 0f61d7dbab24988a50c1c0a9dce528cf792ca53b5f4c60f00fd9dabfd3d3e109f2d245867bc1ebb8294fb84343907e3593c416341ea1b0d7ae626cda8a3218d3 SHA512 625a585915d338fe8ef2f37c5b5bc024f769a623380b85725bcf33686e4cc62a211c2e91552e093dee940367b0d2ad306c5cbe7f1e8f1574eb731d128b8e22bd
EBUILD line_profiler-2.0.ebuild 674 BLAKE2B f3223c39f2d1c22b71adff9073156b59301bd96a34f9826707344a7a6e012ed07616642808061bf8cc7b85054041268b5ae69eb8adb77de0c413b702f027ed88 SHA512 cba4c9e90871b52c89c5654dde6cdfe9a24910d9613938f69af54101afd48eff7059c34a36a47be367a97c6a4f46aab6a5d3693633b931b31ddae06d42387a60
+EBUILD line_profiler-2.1.2.ebuild 668 BLAKE2B 5f7e53da28d326dc6cf69861129902fd45971fa784631ed643bc0417c70e102f5d7e3c284f915174dcfe704b945203df8679731248f509a181a3ac1e56957d7c SHA512 0fd8d10dd9e1fb364e6c79149377f54e343c2c18c36a471c1274854ae3fb5146cff5d04e4ed5715744d8031b4d42d96fefa27bf5144fc320f7ceff11c2c8e3d3
EBUILD line_profiler-9999.ebuild 582 BLAKE2B 5faee1ec552d26cb8f329f63785bf09239766282ea120fa4e73b51aeb24ab9bc7c4770fd74fbb34306448f2f41a1db491ffdbf5ecb716bcdda3fc1b9b3719683 SHA512 4f50a2bf39ceb6d132c74705358d396ed5ff341fd8cda88f29c8cd5427a32e65c37c5c358ea620c3ca8fa85fa52c974bfd711df465c51f1bb778a196ae923662
-MISC metadata.xml 810 BLAKE2B c33c34783a48453f89533d8b65966034b7a88e99ac45d1cd6e2bfc9732f6181dde1661fdfae9fa913440aa6e1ec168a4386b9f7d7c5a127ba6cf33cf3fdf4a35 SHA512 6369d88b7412ba45e4d38bce909c198dc35db0e163e751f35b17b38739283fbb5b6d7da23e5cf147c4fcc08ebde39c394a8cef1e32d02de273fed1ad55552cea
+MISC metadata.xml 948 BLAKE2B 98a4791e0201690c210cd9460be2c17378a360c9dce1502f3293e26468f94aa0c20b28844e41e6e43acd049152057726b4e12f4f7b2a99e0ad38a73296d12403 SHA512 bc38bde3c69ae03dc884b60a55eaaa0b039119d31a552083d22baca047f102f7519606ca2219578b3a9ed3dcf40a68f6aa0dc8508e7258f0a6a993b2ab7a0461
diff --git a/dev-python/line_profiler/line_profiler-2.1.2.ebuild b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
new file mode 100644
index 000000000000..e1ffa748f501
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/rkern/line_profiler
+ https://pypi.python.org/pypi/line_profiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/line_profiler/metadata.xml b/dev-python/line_profiler/metadata.xml
index a5ab15f42671..646d50c3d2b7 100644
--- a/dev-python/line_profiler/metadata.xml
+++ b/dev-python/line_profiler/metadata.xml
@@ -9,6 +9,10 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
<longdescription>
line_profiler is a module for doing line-by-line profiling of
functions. kernprof is a convenient script for running either