summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler/line_profiler-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/line_profiler/line_profiler-2.1.2.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-2.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/line_profiler/line_profiler-2.1.2.ebuild b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
new file mode 100644
index 000000000000..e1ffa748f501
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/rkern/line_profiler
+ https://pypi.python.org/pypi/line_profiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}