summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-13 18:18:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-13 18:18:15 +0100
commitb8330d80ce605a72596ccfa1bfc087b9ded559b8 (patch)
tree209587b26d39505ff0a0c21c2f20ef51652688e9 /dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild
parent41c2683a5cfac2bd3280dc5d5aaed73b6c377bcf (diff)
gentoo auto-resync : 13:10:2023 - 18:18:15
Diffstat (limited to 'dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild')
-rw-r--r--dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild b/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild
new file mode 100644
index 000000000000..364da459eeca
--- /dev/null
+++ b/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-path/
+ https://github.com/p1c2u/jsonschema-path/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-path/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pathable-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ # remove random pins due to caret operator
+ sed -i -e 's:\^:>=:' -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}